[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnucap-devel] gnucap development snapshot 2013-04-23

From: al davis
Subject: Re: [Gnucap-devel] gnucap development snapshot 2013-04-23
Date: Thu, 25 Apr 2013 17:32:15 -0400
User-agent: KMail/1.13.5 (Linux/2.6.32-5-amd64; KDE/4.4.5; x86_64; ; )

On Thursday 25 April 2013, Felix Salfelder wrote:
> On Thu, Apr 25, 2013 at 02:00:52PM -0400, al davis wrote:
> > I do think the "apps" part is up for discussion.  As it
> > stands,  "apps" is all of the plugins that are loaded by
> > default. Should it be split, perhaps "devices" "commands"
> > etc.??  Should they be compiled one by one and a config
> > file lists which to add?

On Thursday 25 April 2013, Felix Salfelder wrote:
> unfortunately "apps" leaves a bad taste nowadays, which
> probably was not intended. so i'd vote for renaming (while
> we're at it). "lib" is a possible name for the loadable
> modules directory (the terminology used in DLOPEN(3) is
> "dlopen() loads the dynamic library [...]"). also "plugins",
> or "modules" is fine but has more characters.

That part is fine with me.  apps becomes either plugins or 
modules.  any preference which?  

The old way (just prior to this change) unpacks the optional 
plugins in "plugins" .. so I think I prefer "modules".

"apps" came from something in GNU discussion about GPL vs LGPL.  
At one point, there was some pressure to do something to allow 
distribution of proprietary plugins, so I was questioning just 
how and where to draw the line.  Looking at the text of LGPL, it 
refers to "applications", so the word stuck.

So, "apps" will change to "modules"??
leaving "plugins" for the ones NOT loaded by default.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]