[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unexpected logging from gpsd

From: Mick Durkin
Subject: Re: Unexpected logging from gpsd
Date: Thu, 14 Oct 2021 15:35:42 +0100
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Thunderbird/91.2.0

Hi Gary,

Yup, it seems ok now. Glad I wasn't going nuts...

You said:-

Installing into /etc usually requires you do it as root.  In your case
it still worked:

I was in my normal user directory as I normally work on the code as that user, 
only changing to root
to run the actual install phase. This time however, I ran the whole show as 
but still within my normal user tree. That's why the install worked correctly.

I attach the same format of logs as last time in case they are of any use. I 
added checks for any libgp* files. I only searched under /usr, as lib and lib64 
are symlinks
to the /usr tree on this distro.

Thanks for the prompt attention (as always!).


Mick Durkin

On 11/10/2021 19:04, Gary E. Miller wrote:
Yo Mick!

On Mon, 11 Oct 2021 11:25:12 +0100
Mick Durkin <> wrote:

I removed gpsd with "scons uninstall" and then deleted the entire
gpsd directory.

That will not remove any gpsd installed another way.  That needs manual
chacking.  Can you look under /lib* and /usr/lib* for any leftover
gpsd libs?  And /usr/include for leftover header files?

I then pulled a fresh copy from the repository and did a full "scons
&& scons check && scons udev-install". This went without any problems
that I could see apart from some warnings about missing stuff that
seems to be related to graphical things (this is a text-only server).

I note this;
$ cd gpsdscons && scons check && scons udev-install

Installing into /etc usually requires you do it as root.  In your case
it still worked:

     mkdir -p /lib/udev/rules.d
     cp /home/mick.durkin/gpsd/gpsd-3.23.2~dev/gpsd.rules 

I then started gpsd with my normal "gpsd -n /dev/ttyS0" and ran the
gpsdebuginfo script, logging these steps to the attached

Odd, you are on Intel, but a Raspberry Pi option got turned on:

     # Magic Hat enabled.

But, unrelated.

The bottom of this log also includes a couple of short snapshots of
"tail -10 /var/log/messages" which show the output I originally found
still appearing.

Yeah, weird.  Just the messages from the PPS thread.  Never seen/heard
anything like that.

Below you said "All the time?  I thought you said only for PPS
stuff?", what I meant was that I see these PPS logs all the time. I
do not see any output from the non-thread parts of gpsd.

Yeah, I see that now.  And "gpsd -n /dev/ttyS0" is running, just as
you said.

The thread specific output is something I have not worked with as
either it is more recent than the versions of gpsd I have worked with
or it never came to my attention before.

It is at least 15 years old.  I still find corners of the code that I
did not know existed.

I certainly never set
anything deliberately to trigger these thread related logs.

Nor is there anything that you can do to only trigger PPS logs.  OTOH,
something in your syslog rules could be selecting just the PPS stuff.
Maybe run "gpsd -nN /dev/ttyS0" to rul that out.

If there is any other information or logs I can supply, please let me

Uh, oh.  Looking at ppsthread_hook() and my recent changes, it looks
like I moved a redundant check out of gpsd_vlog(), only it was not
redundant.  Not sure why I can't duplicate your problem, but I see
my mistake.

Fix pushed to git head, thanks for your help, please test.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703  Tel:+1 541 382 8588

        Veritas liberabit vos. -- Quid est veritas?
     "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: gpsdebuginfo.log
Description: Text document

Attachment: install.log
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]