[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

NF4 and GRUB 0.97 not working - err 16, 18, 25

From: Jan Wagner
Subject: NF4 and GRUB 0.97 not working - err 16, 18, 25
Date: Mon, 28 Aug 2006 11:05:03 +0300 (EEST)


got an odd problem, GRUB 0.95 and 0.97 mysteriously refuse to boot beyond
stage 1.5 on an nForce4 chipsetted mobo (Asus A8N-SLI Deluxe).

I've tried several parallel ATA disks (40GB, 120GB, 250GB), and also
using a /boot partition at the start of the disk instead of just a single
/ plus swap, but to no avail.

When I move the exactly same test disks created on the A8N-SLI PC to
different PCs (tried 2), they boot just perfect on those, with GRUB menu
and all.

Even when installing Fedora Core 5 or Debian 3.1 on the A8N-SLI PC, the
entire setup process completes fine, but upon reboot grub gives
alternatively errors 16, 18 or 25.

Wiping the beginning of the disk with dd if=/dev/zero for a few blocks,
then reinstalling e.g. FC5, the problem still persists.

So on the A8N-SLI Deluxe apparently no matter what, GRUB gets stuck on
stage 1.5, no menu.

Any ideas?

I already did update-grub, grub-install /dev/hda --recheck, after
booting with a recovery CD and chrooting to /dev/hda. Grub appears to
install itself just fine, but booting still gives those errors.

Any thoughts on what to try next?

Some grub info (though I'm not sure if this is GRUB config issue since the
same disk will boot to grub menu properly on a different PC...):

/boot/grub$ cat
(fd0)   /dev/fd0
(hd0)   /dev/hda
(hd1)   /dev/sda
(hd2)   /dev/sdb
(hd3)   /dev/sdc
(hd4)   /dev/sdd
/boot/grub$ cat menu.lst
(snipped the comments)
default         0
timeout         15
color cyan/blue white/blue
# kopt=root=/dev/hda1 ro bigphysarea=16000 ide=nodma
# groot=(hd0,0)
# alternative=false
# lockalternative=false
# altoptions=
# howmany=all
# memtest86=true

title           Debian GNU/Linux, kernel
root            (hd0,0)
kernel          /boot/vmlinuz- root=/dev/hda1 ro
bigphysarea=16000 ide=nodma
initrd          /boot/initrd.img-

title           Debian GNU/Linux, kernel memtest86
root            (hd0,0)
kernel          /boot/memtest86.bin
/boot/grub$ sudo fdisk -l /dev/hda

Disk /dev/hda: 40.9 GB, 40982151168 bytes
255 heads, 63 sectors/track, 4982 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1824    14651248+  83  Linux
/dev/hda2            1825        2189     2931862+  82  Linux swap /
/dev/hda3            2190        4982    22434772+  83  Linux

 - Jan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]