[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Split big and little endian BeFS and AtheFS

From: Vladimir 'phcoder' Serbinenko
Subject: Re: [PATCH] Split big and little endian BeFS and AtheFS
Date: Fri, 21 Aug 2009 00:47:33 +0200

On Fri, Aug 21, 2009 at 12:16 AM, Pavel Roskin<address@hidden> wrote:
> On Wed, 2009-08-19 at 12:05 +0200, Vladimir 'phcoder' Serbinenko wrote:
>> > I'm fine with the split, but please use something more descriptive than
>> > U16, U32 and U64.  Maybe fs_to_cpu16() etc.
>> >
>> U* was here before me but here is a patch w/o them
> Sorry, I didn't realize that.  Then maybe it would be better to apply
> that part separately after the split.
Well it will make a new series of hunks go through the same lines. It
would change U32(x,y)->U32(y)-> grub_afs_to_cpu32. I prefer the
> Please define macros with arguments.  It makes the code more readable.
> Please don't introduce excessively long lines in *.rmk files.  Newlines
> are cheap :-)
I used sed to add new files due to excessive duplication in our build system.
> I don't think we should rename "byte_order" to "unused".  Just because
> we doesn't use it now to determine the endianess, it doesn't mean that
> the field becomes meaningless.  We may want to check it in the future.
Ok. Even if getting reading this field right is tricky (it's used
somewhat strangely and differently on AtheFS and BeFS).
> There are other fields in the superblock that we don't use, such as
> "flags", yet we don't rename them to "unusedN".
Actually some of these fields (e.g. log handling) may even be
different on BeFS and AtheFS but I'm ok with keeping current names.
> Apart from that, I'm fine with the patch.
> --
> Regards,
> Pavel Roskin
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'phcoder' Serbinenko

Personal git repository:

Attachment: fsendian.diff
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]