[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Split big and little endian BeFS and AtheFS

From: Vladimir 'phcoder' Serbinenko
Subject: Re: [PATCH] Split big and little endian BeFS and AtheFS
Date: Sun, 23 Aug 2009 13:04:30 +0200

On Sun, Aug 23, 2009 at 12:40 PM, Robert Millan<address@hidden> wrote:
> On Thu, Aug 20, 2009 at 06:16:24PM -0400, Pavel Roskin wrote:
>> I don't think we should rename "byte_order" to "unused".  Just because
>> we doesn't use it now to determine the endianess,
> Shouldn't we be checking for it?  (and error out if mismatch).
This field is unstraightforward to use. We already have the same
information from the magic (which is stored in native-endian). I feel
like checking additional field will just lead to rejected FS
especially if I don't get this field right. In other words I prefer to
keep complexity to minimum especially in parts of code not used
> --
> Robert Millan
>  The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and
>  how) you may access your data; but nobody's threatening your freedom: we
>  still allow you to remove your data and not access it at all."
> _______________________________________________
> Grub-devel mailing list
> address@hidden

Vladimir 'phcoder' Serbinenko

Personal git repository:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]