[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile 2.0.9 build on mingw

From: Panicz Maciej Godek
Subject: Re: guile 2.0.9 build on mingw
Date: Sun, 26 May 2013 22:41:16 +0200

2013/5/20 Andy Wingo <address@hidden>
On Mon 20 May 2013 22:05, Eli Zaretskii <address@hidden> writes:

>> Date: Mon, 20 May 2013 21:46:02 +0200
>> From: Panicz Maciej Godek <address@hidden>
>> I'm trying to build guile on mingw, but i get the following error:
>> the instruction at 0x7059fe6b refrenced memory at 0x00000004 the memory
>> could not be read
>> The error appears at the stage
>>   GEN      guile-procedures.texi
>> but when I ask make to keep going, the same error appears when guilec tries
>> to compile ice-9/eval.go.
> I reported a similar problem here:
> So far no replies.  I hope to hear from them some day.

Thanks for the ping :)  Can you run meta/gdb-uninstalled-guile and get a
backtrace somehow?  Do you know what source line this error is coming
from?  I've only cross-built and not actually tried to run Guile on
native MinGW.

I don't know how to handle more advanced debugging methods, but perhaps it might be helpful to note that in case of GUILEC, the error pop-ups almost simultaneously with a notice from make, which states that it wrote the .go file.
I include the standard output and error logs from make -k.

After some cheap cheats with makefiles (i.e. replacing the guile-procedues.texi rule with "touch $@" in libguile/Makefile, and touching libguile/guile-procedures.txt) I finally managed to make -k install (the "-k" option was needed, because there was no file named guild.exe, and I don't think that there's supposed to be one).

When I run it for the first time, I got the following message:

Throw without catch before boot:
Throw to key misc-error with args ("primitive-load-path" "Unable to find file ~S in load path" ("ice-9/boot-9") #f)Aborting.

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
Cannot exit gracefully when init is in progress; aborting.

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

I therefore decided to show guile explicitly where it should look for modules:
$ GUILE_LOAD_PATH=/usr/share/guile/2.0

It opened and started to compile the modules, although initially it was complaining that there was no language scheme nor tree-il, and the auto-compilation process stalled when compiling ice-9/threads.scm 

The aforementioned complaints didin't appear when I ran guile for the second time, but then I obtained a lot of messages like:
;;; compiling C:/msys/share/guile/2.0\language\assembly.scm
;;; it seems C:/msys/share/guile/2.0\language\assembly.scm
;;; is part of the compiler; skipping auto-compilation

it sort of stalled after having skipped the srfi\srfi-11.scm module, so I decided to run it for the third time, this time passing GUILE_AUTO_COMPILE=0 as well, but then the interpreter started without any prompt, as if it was dead (although it did terminate with Ctrl+C). I also decided to see whether it could be readline's fault (or something), so I ran it passing the --version arg, but it didn't change anything.

I attach the make logs, unfortunately in two distinct files for stdout and stderr, loosing the chronology of messages. During compilation to .go files, the error messages came after the "wrote `*.go'".

Best regards!

Attachment: make.err
Description: Binary data

Attachment: make.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]