[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ossaulib dbus error

From: Neil Jerram
Subject: Re: ossaulib dbus error
Date: Tue, 22 Jul 2014 18:05:38 +0100
User-agent: Roundcube Webmail/0.9.5

On 2014-07-22 17:39, Max wrote:
I've copied glib/ to neil/, replaced all the instances of glib with
neil (except for
libglib of course :) and tried to use (neil dbus) but the result is
exactly the same
- ERROR: no code for module (neil dbus)

OK, sorry to take your time on that attempt.

What if you do "guile --debug test.scm" where test.scm has just the load-path appending and (use-modules (glib dbus)) ? If that still doesn't work, then clearly this is nothing to do with guile-gnome.

Could it be that one or more of the calls like (dynamic-link "libgio-2.0") are failing? These are executed during module loading, and I think could cause the "no code" error if they throw an exception. To allow these calls to succeed, you need to have installed the -dev or -devel package that provides <name>.so; e.g. the libglib2.0-dev package (on Debian) for

Can you try it on your machine alongside with guile-gnome?

I can try that later this evening. Right now I'm afraid I'm not at the right computer for that.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]