[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ossaulib dbus error

From: Neil Jerram
Subject: Re: ossaulib dbus error
Date: Wed, 23 Jul 2014 09:59:43 +0100
User-agent: Roundcube Webmail/0.9.5

On 2014-07-22 19:46, Max wrote:
22.07.2014 19:05, Neil Jerram пишет:
On 2014-07-22 17:39, Max wrote:

OK, sorry to take your time on that attempt.

What if you do "guile --debug test.scm" where test.scm has just the load-path appending and (use-modules (glib dbus)) ? If that still doesn't work, then clearly
this is nothing to do with guile-gnome.

Sure thing - this is my test file:

(set! %load-path (append %load-path '("/home/lol/source/lisp/ossaulib/")))
(use-modules (neil dbus))

Here is the compilation results:

guile-gnome-2 --debug

;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
;;;       or pass the --no-auto-compile argument to disable.
;;; compiling /home/lol/source/lisp/dbus-test.scm
;;; WARNING: compilation of /home/lol/source/lisp/dbus-test.scm failed:
;;; ERROR: no code for module (neil dbus)

Changing "neil" to "glib" only changes the name in the error message above. I'd
appreciate any hints with debugging. Do you have some small test
application I can use?

Just remembered / worked this out. The problem is that %load-path isn't extended when dbus-test.scm is being compiled, and the solution for that is to use 'eval-when'. Here's my test script, showing the use of eval-when:

(eval-when (expand load eval)
  (set! %load-path (append %load-path '("/home/neil/ossaulib"))))
(use-modules (glib dbus))


reply via email to

[Prev in Thread] Current Thread [Next in Thread]