[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNOME 3.30: help needed!

From: Ricardo Wurmus
Subject: Re: GNOME 3.30: help needed!
Date: Wed, 09 Jan 2019 16:15:28 +0100
User-agent: mu4e 1.0; emacs 26.1

Hi again,

I wrote:

>>> I rebase wip-gnome3.30 on top of the master branch and reconfigured, but
>>> I cannot get GNOME to start. I deleted the slim-service-type and added
>>> (gdm-service) to my configuration.
>>> I moved ~/.xsession out of the way, but after logging in GNOME still
>>> won’t start. Could you share your configuration file that you used to
>>> successfully start GNOME 3.30?
>> * I use wip-gnome3.30 branch and then apply the mentioned patches!.
>> * I do not use the .xsession file.
>> * After testing and reconfiguring my system several times some files in 
>> `/var/lib` were outdated; and renamed '/var/lib` and then reconfigured my 
>> system.
> I removed ~/.cache and ~/.config/gnome*, and I moved .xsession out of
> the way, but I still cannot start GNOME.  GDM comes up fine, but after
> inputing my credentials the mouse cursor skips to the bottom right
> corner and then I’m thrown back into the GDM login screen.
> There is nothing relevant in /var/lib, I think.
> I’ve also tried to do this in a VM, but everything is terribly slow, so
> I can’t get past the GDM login screen.

Ludo reminded me that the VM script defaults to allocating only 256MB
RAM.  After passing “-m 1024” things worked just fine.  I could
successfully log into GNOME.

Sorry, Rene, for the confusion!

Now the only remaining question is: what files on my system cause this
failure to start GNOME?  I’ll be playing with this some more and hope to
identify the files that are responsible, so that we can either work
around this or document it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]