[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Plan for a release!

From: jbranso
Subject: Re: Plan for a release!
Date: Thu, 05 Mar 2020 04:54:21 +0000

Well I finally got around to doing some testing on my Macbook Pro circa 2008.  
I built the installer image just today with 

     guix system disk-image --file-system-type=iso9660 \

joshua@dobby ~$ guix describe
Generation 45   Mar 03 2020 23:16:24    (current)
  jmacs 54f8408
    repository URL:
    branch: master
    commit: 54f84080d7459e74cd33cf434c1077c082ce6508
  guix 4b759d3
    repository URL:
    branch: master
    commit: 4b759d3c548270eba348521669bae15c9e5b72bc

In the past, I had to run open the grub command promt and run "configfile 
(hd0,msdos)/boot/grub/grub.cfg".  Guix's installer does now allow me to see the 
"EFI boot" option when I hold down the "option" key on start up.  That is an 

I had to test the manual installation method.  The graphical installer does not 
work on my macbook.  It just flickers on and then off.  Shortly after grub 
boots into the installer, I briefly see a blue screen, then black, then blue, 
then black, etc.  I can switch to a virtual console and proceed with the 
installation that way.  Perhaps, we should try to start the graphical installer 
only 5 times.  If it fails, then just produce an error message and suggest the 
user switch to another virtual console and try the manual install.

Manual install worked.  I had a weird issue when I made the btrfs filesystems.  
"mkfs.btrfs -L my-root /dev/sd3" gave me an error like "failed to execute 
/gnu/store/eudev/santsnthsnthau32psu/lib/udev ID_BTRFS_READY=0", and it 
repeated on every boot.   The error message on each bot looked like:

udevd failed to execute /gnu/store/eudev/santsnthsnthau32psu/lib/udev 

I configured EFI boot with 1 btrfs partition.  I enabled gnome, mate, xfce, and 
enlightenment services.  The install took about an hour.  In the past, I 
configured a minimal install with no desktop services or window manager 
services.  I have found that trying to install a desktop service fails halfway 
through.  However, this time,  the install worked just fine.

GDM started just fine.  It even recognized my dvorak layout.  It did not in the 
past.  Progress.

I first tested Gnome.  Gnome took a long time to fully load.  I had a mouse 
that could move around for 5+ minutes with no background image before the 
"Welcome to Gnome" screen popped up.  I navigated through the default gnome 
setup easily.  No issues.  Gnome appeared to be working just fine.

Next I tried testing Enlightenment, which started just fine.  The Enlightenment 
welcome dialog started first.  I clicked through a few screen, but it appeared 
to get stuck picking default mouse bindings.  The dialog box said,  
"Enlightenment sets default mouse bindings for objects".  It hanged on that 
screen after I clicked "Alt" for 10+ minutes.  I did a hard reboot, which is 
what really screwed me.  I should have switched to a virtual console and tried 
to shut off that way.

Anyway, after hard rebooting, grub attempted to load my OS.  The grub screen 
went away, and the boot process showed a cursor, but no text.  I waited for 5 
minutes before hard rebooting.  I got the same issue.  So my Macbook Pro 
currently has no OS on it.  :(  But my ThinkPad T400 works just fine!



P.S.  If anyone has any suggestions of where I can look for errors, please let 
me know.  I would be happy to try installing again.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]