[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Plan for a release!

From: jbranso
Subject: Re: Plan for a release!
Date: Thu, 05 Mar 2020 13:42:29 +0000

Well I re-installed guix again just now, so that I could test Xfce and MATE. 
(1) Since I knew that
gnome worked just fine, I decided not to include the gnome service in my 
config. I also decided not
to include the enlightenment environment.

tl;dr  Xfce worked fine, and MATE failed to launch any applications.

The first oddity, was GDM. It worked just smoothly, but the default drop down 
shows that by default
I am going to boot into Gnome. I don't even have the gnome service in the 
config. That's a bit odd.

Xfce worked just fine. It took about 15+ seconds for the desktop background to 
appear, but it
appears to be running smoothly. However, there does not appear to be a browser 
installed by
default. Clicking on the browser icon gives me a pop up message "Choose 
Preferred Application". The 
drop down does not list any programs. I manually installed icecat. Perhaps the 
manual should mention 
that we have not packaged firefox. Instead we have icecat. Also, I used to have 
problems with my mouse 
only moving up and down in guix when I use an apple laptop. This appears to be 
resolved. Nice work guys!

After Icecat was installed, clicking on the browser button allowed me to choose 
icecat as my default browser, and I was able to browse the internet just fine.  
I logged out of Xfce.

Mate started just fine.  I did get a pop-up message 


Authentication is needed to run mat-power-backlight-helper.  I put in my 
password, and the dialog went away.  I did not seem to be able to launch icecat 
with the Application menu.  The Icecat logo was in the applications menu, but a 
popup said "Could not launch GNU Icecat Web Browser".  The error message is 
"Failed to execute child process "gio-launch-deskop" (No such file or 
directory).  I also could not launch mate terminal for the same reason.  
Actually very few applications could launch.  I could get the file browser 
(thunar?) to open, but not much else.  Since MATE did not seem to work so well, 
I logged out.



1. I wish I knew how I could have reconfigured my laptop instead of 
reinstalling everything. I
tried this.

chroot /mnt;
guix system reconfigure /mnt/etc/config.scm;

I got an error that said that guix could not access the build daemon inside the 
chroot. I wasn't
sure how to fix that.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]