[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health-dev] newbie in trouble (Jakob Lang)

From: Roberto Novaes
Subject: Re: [Health-dev] newbie in trouble (Jakob Lang)
Date: Wed, 17 Sep 2014 13:49:09 -0300

Hello Jakob!

Hi GNU health community,

I tried to install all packages required by GNU health and so setup a local
finally everything looked good and I did not get anymore errors but now I
can not connect to the server with the tryton client.
I searched quite some forums for anything that might be wrong but was not
able to find anything that helped.

So here is what I did:
I followed the installation guide of GNU health (and hab additionally to
install the packages python-dev libxml2-dev libxslt-dev zlib1g-dev
postgresql-server-dev-9.3 to get it to install. The OS it is installed on
is Ubuntu.
Now I started the tryton server (trytond) with the settings for
If I start the tryton client and tell him to look for localhost and port
8000 it tells me "Could not connect to the server". netstat tells me that
the server is running ipv4.
I already tried to disable the firewall in Ubuntu via sudo ufw disable

I have no more ideas what might be wrong or what I can try to make it work.

Can you please help me?

Thanks very much in advance!

Are you running the client and the server on the same machine? If you are running the client on a different machine, you must set:

jsonrpc = *.8000 on the trytond/etc/trytond.conf file.

As far as I know, Ubuntu comes with all ports open by default, so it should not be your problem (unless someone has made a different configuration on a legacy server, for example).

Hope it helps.

Roberto Novaes
Sílex Sistemas

reply via email to

[Prev in Thread] Current Thread [Next in Thread]