help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ispell/hunspell/Windows: a fully-worked example


From: AW
Subject: Re: ispell/hunspell/Windows: a fully-worked example
Date: Fri, 04 Apr 2014 12:29:12 +0200
User-agent: KMail/4.12.4 (Linux/3.14.0-22.g79de0a7-desktop; KDE/4.12.4; x86_64; ; )

Am Freitag, 4. April 2014, 00:41:50 schrieb djc:
> I may have omitted a small step.  The dictionary alist contains arguments to
> specify personal word files for the three languages:
> 
>     D:\hunspell\share\hunspell\personal.en
>     D:\hunspell\share\hunspell\personal.de
>     D:\hunspell\share\hunspell\personal.fr
> 
> It may be necessary to create those files, empty if you wish, before using
> them; that's safest, in any case.  You can choose any names for them.

Thank you very much for you help, I used your description, but without 
success! (Win 7, Emacs 24.3) 

However, I downloaded hunspell as source code and compiled it with a recent 
installation of cygwin, so one does not depend upon binaries. I followed the 
instructions given. 

The personal dicitionary has been created.  Hunspell works, I can ask on the 
commandline for the dictionaries (hunspell.exe -D spills out the path and the 
files). 

When I start flyspell (M-x flyspell-mode), Emacs sends the message: 
┬╗Starting new Ispell process [C:/Program files (x86)/GNU Emacs 
24.1/aspell/bin/aspell.exe::default] ...┬ź

This is really strange, because  the path to emacs ist C:/Program files 
(x86)/GNU Emacs 24.3 and not 24.1. I run out of ideas where to look for this 
strange hint to 24.1. There is nothing in my .emacs, nothing in neither path-
variable. If somebody has an idea where I should look, I'd be really glad to 
know. Dam' Windows...

And in the list of processes of Win 7 I find "aspell.exe *32", instead of 
hunspell.exe. 


Regards,

Alexander



reply via email to

[Prev in Thread] Current Thread [Next in Thread]