help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ispell/hunspell/Windows: a fully-worked example


From: AW
Subject: Re: ispell/hunspell/Windows: a fully-worked example
Date: Fri, 04 Apr 2014 14:47:13 +0200
User-agent: KMail/4.12.4 (Linux/3.14.0-22.g79de0a7-desktop; KDE/4.12.4; x86_64; ; )

Am Freitag, 4. April 2014, 13:42:20 schrieb Eli Zaretskii:
> > From: AW <address@hidden>
> > Date: Fri, 04 Apr 2014 12:29:12 +0200
> > 
> > When I start flyspell (M-x flyspell-mode), Emacs sends the message:
> > Ā»Starting new Ispell process [C:/Program files (x86)/GNU Emacs
> > 24.1/aspell/bin/aspell.exe::default] ...Ā«
> 
> You have aspell (a different speller) installed at that directory, and
> Emacs finds it before it find hunspell, probably beacuse of the order
> of directories in your Path.
> 
> To work around this, either uninstall aspell, or put this in your
> ~/.emacs:
> 
>   (setq ispell-program-name "x:/path/to/hunspell.exe")

Thank you, I had written this into my .emacs, without any success. 

If I start Emacs with "emacs -q" on the commandline and than type M-x flyspell-
mode, Emacs finds hunspell and starts it without any further ado! And that 
despite the really long path to hunspell, which is burried in 
C:/cygwin64/usr/local/bin !

If I start Emacs even with an empty (everything commented out) .emacs, M-x 
flyspell-mode tries to start that aspell.exe, which no longer exists (I renamed 
the folder)!

???? What is Emacs checking, even if the .emacs is empty, and what is the 
difference to starting it with "emacs -q" ??????????????

Regards,

Alexander



reply via email to

[Prev in Thread] Current Thread [Next in Thread]