help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ispell/hunspell/Windows: a fully-worked example


From: AW
Subject: Re: ispell/hunspell/Windows: a fully-worked example
Date: Fri, 04 Apr 2014 16:00:28 +0200
User-agent: KMail/4.12.4 (Linux/3.14.0-22.g79de0a7-desktop; KDE/4.12.4; x86_64; ; )

Am Freitag, 4. April 2014, 16:03:03 schrieb Eli Zaretskii:
> > From: AW <address@hidden>
> > Date: Fri, 04 Apr 2014 14:47:13 +0200
> > 
> > ???? What is Emacs checking, even if the .emacs is empty, and what is the
> > difference to starting it with "emacs -q" ??????????????
> 
> The site-init file, if you have it.  It's in the manual.

OK, thank you, again. I found "site-start.el", which tells me that it is meant 
to load the files in a "site-start.d" directory. I removed "site-start.el", but 
now Emacs complains:

"File error: Cannot open lad file, c:/Program Files (x86)/GNU_Emacs_24.3/tex-
site.el"

The file tex-site.el is exactly there!

OK, site-start.el belongs to AUCTeX, as far as I can see. Inside the folder 
site-start.de are two files, auctex.el and preview-latex.el

I reinstalled AUCTeX and got the old error back! So the file site-start.el, 
which belongs to AUCTeX does something, which leads to a wrong path.

The file site-start.el has no more content than these lines:

;; Load files in `site-start.d' directory.
(dolist (file (directory-files
               (concat (file-name-directory load-file-name) "site-start.d")
               t "\\.el\\'"))
  (load file nil t t))

This is weird!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]