[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp shows no user/host completions (solved while writing)

From: Michael Albinus
Subject: Re: Tramp shows no user/host completions (solved while writing)
Date: Thu, 24 Oct 2019 21:36:03 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Tassilo Horn <> writes:

> Hi all,

Hi Tassilo,

> with "emacs -q", C-x C-f /ssh:<tab> showed many completions for host
> names but with my custom emacs setup, it just says [no matches].  I've
> debugged around for an hour, started to write this mail, and then
> eventually found the culprit.
> It seems like you absolutely must have the `basic' completion style in
> `completion-styles' or the `file' entry in
> `completion-category-overrides'.  No `basic', no Tramp username/hostname
> completions.
> Just in case someone runs into the same issue...

I cannot reproduce the problem. With a recent Emacs 27.0.50, I run

- emacs -Q --eval "(setq completion-styles '(partial-completion emacs22) 
completion-category-overrides nil)"

- C-x C-f /ssh: TAB

It returns completion /ssh: and /sshx:

- Moving point after the colon, inserting f TAB

It returns all hostnames starting with f. You could apply another letter
but f, of course.

> Bye,
> Tassilo

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]