[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp shows no user/host completions (solved while writing)

From: Michael Albinus
Subject: Re: Tramp shows no user/host completions (solved while writing)
Date: Sun, 27 Oct 2019 09:01:20 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Tassilo Horn <> writes:

Hi Tassilo,

>> Indeed. When I complete "/ssh:f TAB" with one of `emacs21', `emacs22'
>> or `basic' in `completion-styles', I see the call
>> (file-name-all-completions "ssh:f" "/")
>> which performs host name completion in Tramp. For the other completion
>> styles, there is just
>> (file-name-all-completions "ssh" "/") ;; for `partial-completion'
>> or
>> (file-name-all-completions "" "/") ;; for `substring' and `flex'
>> or even no call for `initials'.
> Would you consider that a bug?

I'm not sure. But I'm not an expert in completion styles.

> At least from a user perspective, it seems odd that more powerful
> completion styles restrict the completion candidates, though I do
> understand the technical details that lead to the observed results.

I don't understand every completion style as complete. More
sophisticated ones, like `flex', *add* completion options. That's why
they are best combined with something like `basic'.

That's not how it is documented. If my assumption is correct, the
documentation shall be adapted. Otherwise, it might be a bug, indeed.

But again, this is out of my knowledge.

> Bye,
> Tassilo

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]