[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Trying to contribute packages: ./pre-inst-env doesn't work

From: Doron Behar
Subject: Trying to contribute packages: ./pre-inst-env doesn't work
Date: Wed, 15 May 2019 11:06:54 +0300
User-agent: NeoMutt/20180716

Hey all,

Coming from Arch Linux, I'm trying to add new packages and contribute
them to the Guix project. However, I have a few doubts as for dictating
a workflow and most importantly I can't seem to be able to actually test
my new packages' definitions with `./pre-inst-env`.

First of all, I'm not sure whether I should define custom channels or
not. After reading the section Channels in the manual, it seemed
reasonable for me that in order to test my fork of Guix, I should create
a branch with my new packages and then test it with `guix pull` and
`guix build`. But `guix search` and `guix build` don't seem to be able
to find the new packages I defined and I couldn't find a way to debug

To be more specific, I've tried this idea by writing the following in

(list (channel
        (name 'guix)
        (url "file:///var/code/doron/guix")))

I ran `guix pull` and it seems it checked out my version of Guix but it
make those new packages available.


Failing to achieve my target with custom channels, I've disabled the
custom channels I configured above and I tried following the
Contributing section in the manual. I jumped straight to the Packaging
Guidelines section and I've done the following:

- I ran ./configure inside /var/code/doron/guix
- I killed the systemd service of guix-daemon and I ran this command:
  `sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild`
- In another shell, I tried running:
  `./pre-inst-env guix build my-new-package`

But it reports that the package `my-new-package` is unknown.


Failing to do that and after looking for alternative ways to create new
packages, I read about the `--load-path` option of `guix build`. Is it
possible to use it for new packages testings? I tried to run the
following but I got all kinds of warnings and errors:

guix build -L/var/code/doron/guix my-new-package

Here is all of the output:

Since there were all of these "source file newer than compiled"
messages, I tried putting back my channels configuration from above and
run `guix pull` again but I got pretty much the same errors and


Any way, I'm very frustrated. Although I'm very excited as for the
genius design of Guix and it's flexibility and extensibility, I'm very
disappointed by it's UX for a simple thing as package contribution. but
this should be addressed in a separate discussion.

I hope someone could help me.

Thanks, Doron.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]