[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to contribute packages: ./pre-inst-env doesn't work

From: Gábor Boskovits
Subject: Re: Trying to contribute packages: ./pre-inst-env doesn't work
Date: Wed, 15 May 2019 12:46:30 +0200

Hello Doron,

Doron Behar <address@hidden> ezt írta (időpont: 2019. máj. 15., Sze,

> To add to my previous message, I'll note that after I `make` finally
> finished, I've encountered the same issue:
> I ran the guix-daemon command:
> sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild

This should only be needed if you don't run it from a service manager.
Changes to the daemon are rare, and most of the times you should be
able to use the old daemon. But this should not cause a problem either.

> Afterwards, in a different shell, I ran
> guix environment guix
> I also believe this is not strictly needed, most of the times it works for
me without this,
once make finished.

> And afterwards, finally:
> ./pre-inst-env guix build my-new-package
> But that returned with the same error that this package doesn't exist.
Could you share the diff?

I don't have any more idea without seeing what you were trying to do.

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]