[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trying to contribute packages: ./pre-inst-env doesn't work

From: Doron Behar
Subject: Re: Trying to contribute packages: ./pre-inst-env doesn't work
Date: Wed, 15 May 2019 17:49:18 +0300
User-agent: NeoMutt/20180716

On Wed, May 15, 2019 at 12:46:30PM +0200, Gábor Boskovits wrote:
> > I ran the guix-daemon command:
> >
> > sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild
> >
> This should only be needed if you don't run it from a service manager.
> Changes to the daemon are rare, and most of the times you should be
> able to use the old daemon. But this should not cause a problem either.

This what the docs say. There's so much room for improvements...

> > Afterwards, in a different shell, I ran
> >
> > guix environment guix
> I also believe this is not strictly needed, most of the times it works for
> me without this,
> once make finished.

O.K, good to know.

> > ./pre-inst-env guix build my-new-package
> >
> > But that returned with the same error that this package doesn't exist.
> >
> >
> Could you share the diff?
> I don't have any more idea without seeing what you were trying to do.

Sorry about that, I've forgot to `git checkout` the branch I was working
on. As I noted in one of my other replies, that's finally working :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]