[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Input method change in GNU IceCat installed via Guix

From: Zelphir Kaltstahl
Subject: Re: Input method change in GNU IceCat installed via Guix
Date: Thu, 16 May 2019 20:06:34 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1


I seem to have solved this issue now. I uninstalled fcitx using apt on
my Xubuntu and then installed it using Guix package manager. After a
relogin (actually restart, but probably relogin is sufficient) I can not
successfully write Chinese characters inside IceCat.

So I guess the learning from this is, that some programs installed using
Guix cannot use system installed tools / libraries and if there is a
problem with a Guix installed program, it is worth a try to install the
other stuff it interacts with with Guix as well and do a relogin to
check, if the program is working correctly then.

Thanks for your help!



On 5/12/19 12:10 PM, Zelphir Kaltstahl wrote:
> Hi Guix Users!
> Recently I installed GNU IceCat via Guix. A few days ago I noticed
> something:
> I cannot switch input method when the GNU IceCat window is focused. My
> shortcut was CTRL+tilde before and I already tried changing it to the
> more common CTRL+ALT+space, but that also does not work. To me it seems,
> that IceCat does not bubble up the keyboard event for this shortcut to
> the system and then the system (Xubuntu 18.04) does not notice, that I
> pressed the input method switching shortcut. But that is only a guess,
> as I do not really know how the order of keyboard event processing is
> organized.
> If it was only switching a few characters on the keyboard, I could live
> with simply typing differently, but when I want to input Chinese
> characters, I currently need to open another program, any text editor
> not having this issue, and then type there and copy paste it into IceCat.
> I am using Fcitx for input method management. My GNU IceCat version is
> `60.3.0esr (64-bit)`.
> Another application where it does not work is Emacs. However, there the
> useful built-in IM exists which can be switched to by: `C-u
> C-<backslash> chinese-py <return>` so I do not need it there.
> What can I do to make IM switching work when IceCat is focused?
> Regards,
> Zelphir

reply via email to

[Prev in Thread] Current Thread [Next in Thread]