[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help Installing GuixSD on ThinkPad X60 tablet

Subject: Re: Help Installing GuixSD on ThinkPad X60 tablet
Date: Tue, 30 Jul 2019 22:53:45 +0000

Hi Vagrant!

That seems logical, but I'm really sure I typed the correct passphrase and yes, 
it only asked me those 2 times, I admit, I typed it incorrectly a couple times, 
but when I did it told me it was incorrect, and asked me the same passphrase 

I used the guix-system-install-1.0.1.i686-linux iso, verified the authenticity 
of the image and got:

gpg: assuming signed data in 'guix-system-install-1.0.1.i686-linux.iso.xz'
gpg: Signature made Sun 19 May 2019 04:47:37 PM EDT
gpg:                using RSA key 3CE464558A84FDC69DB40CFB090B11993D9AEBB5
gpg: Good signature from "Ludovic Courtès <address@hidden>" [unknown]
gpg:                 aka "Ludovic Courtès <address@hidden>" [unknown]
gpg:                 aka "Ludovic Courtès (Inria) <address@hidden>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 3CE4 6455 8A84 FDC6 9DB4  0CFB 090B 1199 3D9A EBB5

And the system configuration (which I had to write down on hand so beware if 
you find any syntactic or semantic errors, I reviewed several times but, in 

(use-modules (gnu))
(use-service-modules desktop networking ssh xorg)

    (locale "en_US.utf8")
    (timezone "America/Santiago")
        (keyboard-layout "us" "alt-intl"))
            (bootloader grub-bootloader)
            (target "/dev/sda")
            (keyboard-layout keyboard-layout)))
        (list   (mapped-device
                        (uuid "xxxx"))
                    (target "cryptroot")
                    (type luks-device-mapping))
                        (uuid "yyyy"))
                    (target "crypthome")
                    (type luks-device-mapping))))
        (cons*  (file-system
                    (mount-point "/")
                    (device "/dev/mapper/cryptroot")
                    (type "ext4")
                    (dependencies mapped-devices))
                    (mount-point "/home")
                    (device "/dev/mapper/crypthome")
                    (type "ext4")
                    (dependencies mapped-devices))
    (host-name "my-hostname")
        (cons*   (user-account
                    (name "my-user")
                    (comment "my-full-name")
                    (group "users")
                    (home-directory "/home/my-user")
                        '("wheel" "netdev" "audio" "video")))
            (list   (specification->package "i3-wm")
                    (specification->package "nss-certs"))
            (list   (service gnome-desktop-service-type)
                    (service tor-service-type)
                    (set xorg-configuration
                            (keyboard-layout keyboard-layout))))

I also saw in the web that only libreboot could see an encrypted /boot, not the 
case for the proprietary BIOS, is that true? Maybe that should be the reason it 
sent me to a Guile REPL?

Thanks for contacting me!

Byron Elías Molina Hermosilla,

Software Engineering Student,

INACAP Renca, Chile.
De: Vagrant Cascadian <address@hidden>
Enviado: martes, 30 de julio de 2019 13:38:43
Cc: address@hidden <address@hidden>
Asunto: Re: Help Installing GuixSD on ThinkPad X60 tablet

> I downloaded the i686 iso and flashed it to a 3.0 USB Kingston
> DataTraveler with Balena Etcher, it worked fine, it booted, I followed
> the graphical install, set the language and keymap, location, and
> chose to use full disk with separate home partition and full
> encryption, I also selected i3 and openbox as desktops and lastly
> mozilla https and tor network.

> It installed without errors, and asked me to reboot, after that it
> asked me the / encryption passphrase, got to the grub screen, then
> asked me the home passphrase, aaand... it booted to Gnu Guile! And by
> typing ",help guix" it only showed me the option to switch to bournish
> language! I read every single command that ",help all" showed me but
> none helped, I saw also something about "repl" in the welcome message
> but tried it and the command didn't work either.

Typically, you need to type in the same passhrase twice for "/", once
for grub and once from the initramfs to mount "/" ... are you sure you
typed the right passphrases in at the right times? If you were only
asked for two passphrases and got a guile prompt after the second
passphrase, this would be my *guess* what happened.

live well,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]