[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Xdm trisquel login fails after installing gajim on a fresh guix install

From: David Lecompte
Subject: Xdm trisquel login fails after installing gajim on a fresh guix install (works after rolling back)
Date: Wed, 02 Jun 2021 08:16:47 +0000

Hi all,

I installed Guix on Trisquel 9 on an X200 following advice from the
section 2 of the manual. I ran the script mentioned in the first note
with sudo and made the guess that it replaces the steps from sections
2.1 up to 2.5 included, even though that is not mentioned.

Then, following advice from section 2.6 and 2.7, I installed the Guix
packages glibc-locales, fontconfig, font-adobe-source-han-sans and nss-
certs, and I installed the Trisquel package nscd. Then I ran guix pull,
guix package -u, sudo -i guix pull and systemctl restart guix-

I understand one needs to run guix pull and guix package -u
periodically, but I don't know whether the last two are also needed as
frequently, I couldn't find any recommendation on that in the manual.

Anyway, the actions and time it took looked similar to when I installed
Guix on another computer running Trisquel 9 before, and everything was
working ok.

One small remark though: at various times, there are messages
recommending to set PATH, GUIX_PATH or GUIX_LOCPATH but these variables
are actually set automatically as part of the installation process, so
these messages are a bit misleading.

Then, when I asked to install the Guix gajim package, to my surprise,
the output said it needs to download more than 100 MB and a crazy number
of packages were processed, among which texlive or xorg, it took at lest
as long as all the previous steps and both cores of my CPU were at 100%
for more than 30 minutes. I'd love to provide some log of the output but
I didn't redirect it to a file and I don't know if that is kept

When it was finished, I logged out and logged in using the default
Trisquel xdm, my password is accepted but after maybe 30s, I get back to
the login screen and any further attempt to log in has the same result.

I logged in a console terminal, and since I did not know what to do, I
rolled back and then I could log in via xdm normally again.

I don't know whether I did something wrong when installing Guix or if
there is an issue with the gajim package, or with installing it in Guix
now, or the combination of both. My Trisquel 9 install is very recent
and Trisquel is highly stable, so I doubt there is anything wrong with

I am happy that rolling back removes the problem but I'd like to find
out how to use guix without breaking trisquel.

Thanks in advance for the help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]