[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Error starting a guix shell

From: Zelphir Kaltstahl
Subject: Error starting a guix shell
Date: Tue, 19 Jul 2022 18:45:04 +0000

Hello Guix users!

Today I had a strange error, when I ran a `guix shell` command:

(repl-version 0 1 1)
(exception %exception (non-self-quoting 140737175054176 "#<&message message: \"unsupported 
manifest format\">"))

This happened with guix on foreign distro and that distro is a Xubuntu 22.04, which I recently upgraded from 20.04 -> 22.04. After that, I think today was the first time I ran that guix shell command. Because of the distribution upgrade, a lot of things can have changed.

This is how I ran the command:

I have an `env.bash` file:

#!/usr/bin/env bash

set -Eeuxo pipefail

DIR="$(cd "$(dirname "${BASH_SOURCE[0]}")" > /dev/null 2>&1 && pwd)"

printf "script directory is: %s\n" "${DIR}"
guix time-machine \
     --channels="${DIR}/channels.scm" -- \
     shell \
     --development \
     --check \

The `manifest.scm` file is:


The `channels.scm` file is:

(list (channel
        (name 'guix)
        (branch "master")
              "BBB0 2DDF 2CEA F6A8 0D1D  E643 A2A0 6DF2 A33A 54FA")))))

However, I unfortunately already updated the `channels.scm` file using `guix describe --format=channels > channels.scm`, so the above file is not the file, with which I had the error, and I have no idea what the channel was before.

When I had the error, I simply ran `bash guix-env/env.bash`, to activate the shell. Then I got an error and guix told me about a log file, some `*.log.gz` file. That one I copied out of the GNU store directory and opened the contained text file. It contained the error I wrote above.

I am aware, that without the exact `channels.scm` file, this might be irreproducible. Sorry about it! When I hit the error, I thought: "Ahh well, quickly update guix and see if it solves it." and I also did the guix describe thingy to update the channel file, because my primary goal was to get the guix shell working again. Only later I thought of still needed that old file, in order to make a proper report. Sorry! After doing the following, it worked again:

sudo -i
guix pull && guix package -u
guix pull && guix package -u
guix describe --format=channels > channels.scm

My question now is, what could have caused the error? I thought, that, if I keep `channels.scm` the same, I would get a reproducible environment, assuming, that guix itself does not change behavior. Also the OS upgrade can of course have interfered and I would not be able to tell. But perhaps my strategy to get reproducible shells is not as safe as I thought? ("Can I still run in this environment/shell in 5 years? In 10? With the same results?")

Best regards and apologies again for the not so precise information,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]