[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: (jhandles installs.... then error) Implementation of "uicontrol" for

From: Pen-Yuan Hsing
Subject: Re: (jhandles installs.... then error) Implementation of "uicontrol" for latest Octave?
Date: Tue, 24 Aug 2010 12:02:45 -0400
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

On 2010/08/23 19:05, Martin Helm wrote:
Am Montag, 23. August 2010, 22:47:40 schrieb Pen-Yuan Hsing:

I also tried the program you linked at:

After downloading and running a few files, it showed an empty window. I
assume there should be more than that?

Is there hope for me still? :)

This is a general applet from to test the java opengl bindings, if
that shows only a black screen and not turning gears it shows that your ubuntu
in virtual box has a deep low level problem. I cannot help with that since I
have not the simplest knowledge about virtual box (I know what it is but
that's all).
I use vmware player and server (free as free beer but not FOSS) and qemu (free
as free speach/FOSS) and have only knowledge about these two.

- mh

OK, since I use a Mac I just tried the whole thing in a Parallels Desktop 5 virtual machine (same configuration).

This time, sombrero and shading interp seemed to work, and glxgears, etc. showed correctly.

However, when I ran my Matlab code, which uses the uicontrol function, I get the following output:

octave:6> mosaic_GUI
error: [java] property not found - Units
error: evaluating argument list element number 1
error: evaluating argument list element number 1
error: called from:
error: /usr/share/octave/packages/3.2/jhandles-0.3.5/__jhandles_get.m at line 41, column 5 error: /home/penyuan/Downloads/photo_mosaic/mosaic_GUI.m at line 7, column 12

BTW, "mosaic_GUI" is the name of the Matlab program I am trying to run.

Is this a limitation on jhandles part? Or is it still a virtual machine issue? Is vmware the only one that is known to work?

P.S. Here is the output from glxinfo, in case it is helpful:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: Parallels Inc
server glx version string: 1.4
server glx extensions:
    GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig
client glx vendor string: Parallels Inc
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_EXT_texture_from_pixmap, GLX_SGIX_fbconfig
GLX version: 1.4
GLX extensions:
GLX_ARB_get_proc_address, GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Parallels and NVIDIA Corporation
OpenGL renderer string: Parallels using NVIDIA GeForce GT 330M OpenGL Engine
OpenGL version string: 2.1 NVIDIA-1.6.18
OpenGL shading language version string: 1.20
OpenGL extensions:
    GL_EXT_texture3D, GL_ARB_transpose_matrix, GL_ARB_vertex_program,
    GL_ARB_vertex_blend, GL_ARB_window_pos, GL_ARB_shader_objects,
    GL_ARB_vertex_shader, GL_ARB_shading_language_100,
    GL_EXT_multi_draw_arrays, GL_EXT_clip_volume_hint, GL_EXT_resca

reply via email to

[Prev in Thread] Current Thread [Next in Thread]