[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ode45 error: dimension mismatch in line 345 column 17

From: Marius Schamschula
Subject: Re: ode45 error: dimension mismatch in line 345 column 17
Date: Thu, 31 Aug 2017 05:49:18 -0500

In MacPorts we still use the old qt (perhaps we should look into the security issues as well).

However, I use Jupyter Notebooks with the octave kernel as my front end, and rarely load the octave GUI anymore.

I have found that this is easier to display to a class when working problems.

On Aug 31, 2017, at 1:48 AM, Sebastian Schöps <address@hidden> wrote:

daltonj283 wrote
So I tried installing Octave using *brew install octave*, and it worked
I was unable to open Octave with the GUI. It would only allow me to use
command line of Octave. So then I tried *brew install octave --HEAD *and
that resulted in the same problem. I even tried the command octave

True. Since homebrew moved to qt 5.9 (which is justified as older version
have significant security issues are unmaintained) we do not build octave
with the GUI anymore. Sorry, it's too buggy to be shipped. Sadly, I have not
the skills to fix the qt issues and the people that might have the skills do
not care about macOS :( For now, you either live with an outdated octave
(using an outdated qt) or a recent octave without GUI.... or you are a qt
expert and you can help me fixing it :)

Personal note: the command line interface is not so bad after all. I would
always go for option 2.


Sent from:

Help-octave mailing list

Marius Schamschula

reply via email to

[Prev in Thread] Current Thread [Next in Thread]