[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with lilypond 2.5.31 under WinME

From: Jan Nieuwenhuizen
Subject: Re: problems with lilypond 2.5.31 under WinME
Date: Mon, 27 Jun 2005 10:08:00 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Brynne and Russ Jorgensen writes:

> When I run lilypond from the desktop, it does not start up lilypad
> with the file.  However, if I start a command
> shell, cd to the LilyPond usr\bin directory and then run lilypond, it
> DOES start up lilypad.  I thought it was a problem quoting spaces in
> the install directory, so I uninstalled and re-installed in a
> directory without spaces, and it's still not working.  I dug a little
> deeper, and I think now that the problem is that lilypond.exe is not
> affecting the environment at all.  I put the following batch file in
> c:\windows to see what lilypond.exe does to the environment:


   LILYPOND_VERBOSE=1 lilypond

prints changed environment settings.

> As you can see, PATH does not contain lilypond\usr\bin, and the
> environment variables aren't set at all!

The environment changes only affect the current process.

> it looks like setup_paths()
> is supposed to be doing this, but it doesn't appear to be working.
> Therefore, whenever lilypond tries to execute a program that it should
> find in its path (lilypad.exe and more importantly also gs.exe), the
> program isn't found. I can't get lilypond.exe to compile, so I can't
> debug any deeper.  Let me know if you have some things you'd like me
> to try...
>       -Russ

Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter       |

reply via email to

[Prev in Thread] Current Thread [Next in Thread]