[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: git push doesn't work

From: Marc Hohl
Subject: Re: git push doesn't work
Date: Fri, 27 Jul 2012 12:20:45 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120714 Thunderbird/14.0

Am 27.07.2012 11:07, schrieb Phil Holmes:
----- Original Message ----- From: "Marc Hohl" <address@hidden>
To: "Trevor Daniels" <address@hidden>
Cc: "David Kastrup" <address@hidden>; <address@hidden>
Sent: Friday, July 27, 2012 8:28 AM
Subject: Re: git push doesn't work

I have saved my public key on savannah, and the instructions say that
it will take some time before it gets activated, so I have to be patient ...

I think it would probably be more accurate to say "may take some time". I believe that every time I've done it, it's been instant. Try a dry run push, and if that works, you're good to go.
I was off to play some music, but back on my computer,

git pull --verbose

still fails.

Here is what I did so far:

After Trevor's mail, I found out that I already *had* .ssh/config|id_rsa| etc.
due to some ssh connections to other servers a friend of mine created for me
(I was sitting next to him, but apparently he can type commands faster than I could think, so I didn't understand what he was doing. Within seconds, he established
some secure connections to servers, and I never cared about this).

So I copied the contents of into the right place on the savanna web site,
and got a mail that it is accepted. Fine.

I changed the .git/config file again to match the description:

url = ssh://<username>

(well, I inserted my *real* username in the line above!)

and tried the ssh connection with

git pull --verbose

but after two hours or so, I still get
Permission denied (publickey).
fatal: The remote end hung up unexpectedly

I don't understand what's wrong here.



Phil Holmes

reply via email to

[Prev in Thread] Current Thread [Next in Thread]