lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUB lilypond build fails


From: Andrew Bernard
Subject: Re: GUB lilypond build fails
Date: Mon, 17 Dec 2018 12:41:44 +1100

Hi All,

I am new to lilypond dev. work. My intention may be naive, but I am wanting
to do the work to uplift gub and lilypond to python 3. Am I premature, or
foolish, or misguided? I did have some encouraging email about this
previously, but I just wanted to check before I dive in and spend large
amounts of time, especially re GUB.

Andrew


On Mon, 17 Dec 2018 at 12:16, Carl Sorensen <address@hidden> wrote:

>
>
> ´╗┐On 12/16/18, 4:38 PM, "lilypond-devel on behalf of Werner LEMBERG"
> <address@hidden on behalf of address@hidden>
> wrote:
>
>
>     >    I think you have the same issue me and others had.  You don't see
>     >    it in the tail below, but if you open the lilypond.log file
>     >    you'll see a python command failing to generate a file because
>     >    GUB python is 2.4 while lilypond python code uses if statements.
>     >    It's discussed in one of the pull requests on GitHub.
>
>     I took to liberty to `hotfix' this issue in the lilypond git
>     repository: There was a single place in `musicexp.py' that used 2.5
>     syntax, which I've just changed back to 2.4 syntax in `staging'.
>
> Thank you, Werner!  That is an excellent solution.
>
> We will still want to look into a long-term fix in the build/distribution
> system.  But getting it to work right now is really important.
>
> Thanks,
>
>
> Carl
>
>
> _______________________________________________
> lilypond-devel mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/lilypond-devel
>


reply via email to

[Prev in Thread] Current Thread [Next in Thread]