[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: macOS 64-bit

From: Marnen Laibow-Koser
Subject: Re: macOS 64-bit
Date: Sat, 11 Jan 2020 07:48:26 -0500

On Sat, Jan 11, 2020 at 7:08 AM Dan Eble <address@hidden> wrote:

> On Jan 11, 2020, at 01:36, Marnen Laibow-Koser <address@hidden> wrote:
> > I'd really appreciate fellow Mac users testing the build and reporting
> any
> > issues you find.  (Karlin? Carl?)  You can download it at
> > ; it
> > should work on any recent version of Mac OS.  I'm particularly interested
> > in reports from Catalina users, but really, at this point, any
> information
> > is useful.
> I've never been a LilyPond GUI user,

Neither am I; I use Frescobaldi instead.  The .app bundle is convenient for
packaging dependencies, though, which is why I’m putting the effort into
making it work.

so I first tried to run
> /Applications/ from a
> Makefile on macOS 10.15.2 (Catalina).  (Renaming to include
> the version number has been my practice for a while.)

Could you try it without renaming and see if you get the same results?
 (Renaming shouldn’t actually matter, but I want to make sure I didn’t do
something stupid.)

> There was the usual security problem with running unsigned apps,

which was solved in the usual way in the Security & Privacy preferences
> pane.

What “usual way” is that?  I usually just right-click on the app and open
it and ask it to override, although I didn’t need to do that with this
app.  Perhaps renaming the bundle did something here?

> Near startup, there was this message I don't remember having seen before:
>     Unable to revert mtime: /Library/Fonts
> It probably comes from here:
>     $ (cd /Applications/LilyPond* && grep -r "Unable to revert mtime" .)
>     Binary file ./Contents/Resources/lib/libfontconfig.1.dylib matches

I wonder if that’s an actual problem.

> Next, it looks like gs failed:
>     warning: `(gs -q -dSAFER -dDEVICEWIDTHPOINTS=612.00
> -dDEVICEHEIGHTPOINTS=792.00 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH
> -r1200 -sDEVICE=pdfwrite -dAutoRotatePages=/None -dPrinted=false
> -sOutputFile=ar10_holy_God_behold_my_heart_is_turning.pdf -c.setpdfwrite
> -f/var/folders/3k/ftz328kw8xj94s0059bcsnx80000gp/T//lilypond-zC36CX)'
> failed (256)

How frustrating.  I thought I had fixed this issue.

Would you try running LilyPond from the command line in debug mode ( --loglevel=debug
and let me know what Ghostscript errors you see?

Thanks very much for testing this, and I’m sorry about the lingering
errors.  I’ll try to fix them.

Marnen Laibow-Koser address@hidden Sent from Gmail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]