[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: macOS 64-bit

From: Dan Eble
Subject: Re: macOS 64-bit
Date: Sat, 11 Jan 2020 08:18:26 -0500

On Jan 11, 2020, at 07:48, Marnen Laibow-Koser <address@hidden> wrote:
> Could you try it without renaming and see if you get the same results?  
> (Renaming shouldn’t actually matter, but I want to make sure I didn’t do 
> something stupid.)

same result

> There was the usual security problem with running unsigned apps,
> which was solved in the usual way in the Security & Privacy preferences pane.
> What “usual way” is that?  I usually just right-click on the app and open it 
> and ask it to override, although I didn’t need to do that with this app.  
> Perhaps renaming the bundle did something here?

With command-line programs, there's no right-clicking.  When you try to run the 
program, the OS kills it (signal 9).  If you're lucky, it pops up a dialog box 
explaining that it has done so.  Open the Security & Privacy preferences pane, 
where there is a message that such-and-such was prevented from running, and 
click the button to allow it in the future.

> Would you try running LilyPond from the command line in debug mode ( 
> --loglevel=debug and 
> let me know what Ghostscript errors you see?

Converting to `simple.pdf'...
-dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite 
-dAutoRotatePages=/None -dPrinted=false -sOutputFile=simple.pdf -c.setpdfwrite 

GPL Ghostscript 9.50 (2019-10-15)
Copyright (C) 2019 Artifex Software, Inc.  All rights reserved.
This software is supplied under the GNU AGPLv3 and comes with NO WARRANTY:
see the file COPYING for details.

*** Warning: GenericResourceDir doesn't point to a valid resource directory.
               the -sGenericResourceDir=... option can be used to set this.

  ./base/gsicc_manage.c:1254: gsicc_open_search(): Could not find 
| ./base/gsicc_manage.c:2272: gsicc_init_iccmanager(): cannot find default icc 
**** Unable to open the initial device, quitting.
-dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite 
-dAutoRotatePages=/None -dPrinted=false -sOutputFile=simple.pdf -c.setpdfwrite 
-f/var/folders/3k/ftz328kw8xj94s0059bcsnx80000gp/T//lilypond-gJjMWd)' failed 

fatal error: failed files: "./"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]