[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Another silly font question

From: Phillip Lord
Subject: Re: Another silly font question
Date: 01 Nov 2001 18:53:40 +0000
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

>>>>> "Bob" == Bob Schmertz <address@hidden> writes:

  Bob> On Thu, 1 Nov 2001 address@hidden wrote:

  >> I've been using Lily for about two years now, always compiling
  >> from source, usually with no problems. Having not had time to do
  >> any typesetting for six months or so I thought it was time to get
  >> back to it, and set about installing the latest 'stable' rpm
  >> (Redhat7.1). This is on a completely vanilla installation of the
  >> OS.
  >> After sticking in the RPM, I tried to re-compile some of my old
  >> scores, only to find that it can't find most of the fonts. I then
  >> uninstalled the RPM and tried from the latest source tarball -
  >> again no fonts. I've scanned the FAQ and the last month or so of
  >> this list and can't find anything helpful, so the question is:

  Bob> I'm using Red Hat 7.1.  I have not set up any environment
  Bob> variables relating to fonts, nor anything else that seems to be
  Bob> related to Lilypond, but everything works fine.  I installed
  Bob> from source.

  Bob> The one unusual thing I remember doing was folloiwing the FAQ,
  Bob>, where it says:

  Bob>     In Redhat or Mandrake, with lilypond built from source, the
  Bob> procedure is:

  Bob>  cd /usr/share/texmf/fonts/source/public

  Bob>  ln -s /usr/local/share/lilypond/mf lilypond

  Bob> and I probably ran the 'mktexlsr' after that, as instructed.
  Bob> You made no mention of making any links, so I wonder if that's
  Bob> a question you missed in the FAQ.

          My experience with this is that you need to also comment
out the "MFINPUTS" and "TFMFONTS" lines from
/etc/profile.d/ (or whatever depending on which shell you
use). Otherwise TeX will find the fonts there first before finding
them via the symlink, and still dump the created font locally rather
than in /var/tmp/. 

        This is on RedHat 7.0, using the rpm install of lilypond
though. It's probably different for every TeX installation in the

        Of course this is different form not being able to find the
fonts. Perhaps this might be caused by not having the environment set
up for you, and NOT having the symlink.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]