[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Same error as in November

From: Alan McConnell
Subject: Same error as in November
Date: Sat, 9 Feb 2002 12:46:54 -0500
User-agent: Mutt/1.3.12i


I gave up on LilyPond 1.4.8 in November, and got busy on other things.
But a week or so ago I got version 1.4.9 and today I got a chance to
work on it.   I have made some progress, since my ./configure went
OK(I had managed to install what seems to be a workable libkpathsea).

But my build crashed, basically at the same point as it did in November.
Here are the last few lines:
In file included from /usr/local/include/FlexLexer.h:47,
                 from out/
/usr/local/include/g++-v3/backward/iostream.h:36: using directive `istream' 
   introduced ambiguous type `istream'
lexer.ll: In member function `virtual int My_lily_lexer::yylex()':
lexer.ll:486: cannot convert `std::istream*' to `istream*' in assignment
lexer.ll: In member function `void yyFlexLexer::yy_load_buffer_state()':
lexer.ll:1009: cannot convert `istream*' to `std::istream*' in assignment
lexer.ll: In member function `void 
   yyFlexLexer::yy_init_buffer(yy_buffer_state*, std::istream*)':
lexer.ll:1060: cannot convert `std::istream*' to `istream*' in assignment
/usr/local/include/g++-v3/bits/locale_facets.tcc: At top level:
lexer.ll:122: warning: `int yy_start_stack_ptr' defined but not used
lexer.ll:123: warning: `int yy_start_stack_depth' defined but not used
lexer.ll:124: warning: `int*yy_start_stack' defined but not used
lexer.ll:126: warning: `void yy_push_state(int)' declared `static' but never 
lexer.ll:129: warning: `void yy_pop_state()' declared `static' but never 
lexer.ll:132: warning: `int yy_top_state()' declared `static' but never defined
make[1]: *** [out/lexer.o] Error 1
rm out/
make[1]: Leaving directory `/gamma/music/lilypond-1.4.9/lily'
make: *** [all] Error 2


I am running Debian Woody.

With reference to my system prerequisites, enumerated in the INSTALL.txt
that came with 1.4.9,  I have the following items:

I have gcc 3.0

"python --version" doesn't work; but I have /usr/bin/python _and_

I have guile 1.4

I have GNU Make, of course

"flex --version" returns "flex version 2.5.4" but it is really 2.5.4a,
since I downloaded flex, built it, and installed it as per directions

I have bison 1.28

I have TeX, which has always worked fine for me.  I have installed
the kpathsea libraries; "ls /usr/lib/libkp*" returns

/usr/lib/libkpathsea.a    /usr/lib/
/usr/lib/  /usr/lib/

I don't have texinfo, but I think I have lots of documentation . . .

I have geometry.cfg and geometry.sty, down inside . ./tex/latex/ . . .

I have MetaPost and

        I trust that this list of prerequisites is complete; but maybe not . .

Any suggestions/help would be much appreciated.

TIA and best wishes,


Alan McConnell     An interesting article by Bill Moyers, from "The
http://patriot.    Nation", is to be found, with other good stuff, on
net/users/alan     my web site -- Click on "Public Policy"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]