[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Same error as in November

From: Mats Bengtsson
Subject: Re: Same error as in November
Date: Sun, 10 Feb 2002 17:11:39 +0100

> On Sat, Feb 09, 2002 at 07:57:46PM +0100, Mats Bengtsson wrote:
> >
> > > "flex --version" returns "flex version 2.5.4" but it is really 2.5.4a,
> > > since I downloaded flex, built it, and installed it as per directions
> > 
> > Please read the comment in INSTALL.txt on gcc 3.0 and Flex.
>       I looked through the INSTALL.txt and I am guessing that you
>       are talking about
> >   Flex (2.5.4a-11) in unstable does not produce g++-3.0 compliant C++
> > code.  To compile LilyPond with gcc-3.0, please first upgrade to
> > flex_2.5.4a-13 or newer.  Otherwise, you may do:
>       The flex that I downloaded and installed -- I had to unpack
>       it with ar -- is flex_2.5.4a-22_i386.deb.  I have the right
>       FlexLexer.h, I believe, and the right libfl.a.
> But perhaps you are referring to something else?  perhaps you could be
> more explicit .  .  .

That's the lines I had in mind. I hope you have verified that the
FlexLexer.h that the compiler finds (/usr/local/include/FlexLexer.h
according to your previous mail) really belongs to the same flex
version and isn't left over from some previously installed version.

Also, even if you have the newer flex version, it may be worthwhile
to try also the manual fix described in INSTALL.txt, at least to 
verify that the generated file does indeed include the
header file iostream.h (or fstream.h), see lexer-gcc-3.0.patch.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]