[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: error :GUILE signaled an error for the expression beginning here #

From: ming tsang
Subject: Re: error :GUILE signaled an error for the expression beginning here #
Date: Sun, 11 Jul 2021 15:32:40 -0400

Hi Aaron,
I am confused about this "file information" LSR.
Yesterday, I did a ""file>save as" to a file name to This morning I tried to run the, but I got run error:
As a result I did the following:
1.  run frecobaldi v3.1.3 -- untitled tab appeared and copy LSR-"file information" to the untitled tab. Add \version "2.18.2" at the beginning of the tab. Run lilypond and it works.
I did run a couple times and they worked fine.

2.   I changed the version to \version "2.23.3"  and ran lilypond and it worked. Please note I did not run convert-ly. And it worked.  Confused?
3.  I did file>save as to

4.   I did file manager, selected the files I saved and double clicks to run them and they both failed --  GUILE signaled an error. 

5.  Observations:  
5.1  convert-ly was not needed in this case.
5.2  It seems that running the untitled tab works fine for both versions of lilypond.
5.3  I also noticed that the pdf generated did not match with the LSR "file information".  the \header { dedication = ..... } printout missing or not properly formatted. i.e. missing  .... using scheme "define" .... and .... using "ly:export" ..... in "music view"
5.3  It was hard to decipher "filen" -- it seemed it was in a temporary location. I cannot locate the temporary file location.
5.4  I was hoping by doing "save as", when I ran the file I would get the file name and file location path.  So that this info can be printed on lilypond score output pdf.
5.5  Is there any other way to get the file path (location) and file name from lilypond coding?

Thank you for your help.
yMing Tsang

On Sun, Jul 11, 2021 at 6:08 AM ming tsang <> wrote:
Dear Aaron,
Thank you for the info that the LSR repository is v2.18.2.
1.  I re-install lilypond v2.18.2 
2.  I copy the LSR "file information" to a file.
3.  I ran it with v2.18.2 - successfully executed.
4.  I then apply convert-ly from v2.18.2 to v2.23.3
5.  I ran again in v2.23.3 - successfully executed.
Consider the problem solved! Thanks.

Also thank you to : Knute Snortum; David Kastrup for the help.

Thanks again,
yMing Tsang

On Sat, Jul 10, 2021 at 11:50 PM Aaron Hill <> wrote:
On 2021-07-10 8:46 pm, Aaron Hill wrote:
> On 2021-07-10 7:15 pm, ming tsang wrote:
>> I copied the snippet from the lilypond snippet repository.  There is
>> no
>> lilypond version information.
> Last I checked, the LSR was only up-to-date with 2.18.2.

And confirmed at the bottom of the Contributing [1] page:

> The LSR is currently running LilyPond version 2.18.2.


-- Aaron Hill

ming (lyndon) tsang

ming (lyndon) tsang

reply via email to

[Prev in Thread] Current Thread [Next in Thread]