[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: [lmi] How to build lmi from source on GNU/Linux

From: Vadim Zeitlin
Subject: Re[2]: [lmi] How to build lmi from source on GNU/Linux
Date: Sat, 20 Sep 2008 17:19:48 +0200

On Sat, 20 Sep 2008 14:06:23 +0000 Greg Chicares <address@hidden> wrote:

GC> I don't claim to understand autotools, but I thought I might try
GC> using them experimentally

 Thanks for testing this!

GC> So I tried to follow 'README.auto', but I got stuck. That file says
GC> I need:
GC> | a) GNU autoconf >= 2.56 (2.56 under mingw and 2.59 under cygwin are known 
to work)
GC> | b) GNU automake >= 1.5 (at least; 1.7.9 and 1.9.6 known to work)
GC> | c) GNU libtool >= 1.5 (1.5.20 known to work)
GC> so these Cygwin versions seem okay:
GC> $autoconf --version | head --lines=1
GC> autoconf (GNU Autoconf) 2.61
GC> $automake --version | head --lines=1
GC> automake (GNU automake) 1.10.1
GC> $libtool --version | head --lines=1
GC> ltmain.sh (GNU libtool) 1.5.25a (1.1220.2.458 2007/06/30 09:32:00)

 Yes, they should be. I have the same autoconf but automake 1.9.6
(surprisingly I do have automake-1.10 too but it's not default for some
reason) and libtool 1.5.23a. And I do use automake 1.10 under Linux.

GC> | After a fresh cvs checkout you need to run autogen.sh once.
GC> I first tried running it outside the source directory, but...
GC> $/lmi/src/lmi/autogen.sh
GC> Please run this script from the lmi source directory.

 Yes, it does need to be ran from source directory because it generates the
configure script which must be located there. You can run the configure
script it creates from anywhere (and it's better to do it from another
directory) however.

GC> ...well, okay:
GC> $cd /lmi/src/lmi
GC> $./autogen.sh
GC> Setting up build system for lmi:
GC>  - aclocal
GC>  - libtoolize
GC>  - autoconf
GC> configure.ac:82: error: possibly undefined macro: AC_MSG_ERROR
GC> The most common response to questions like this
GC>   http://www.google.com/search?q="possibly+undefined+macro+AC_MSG_ERROR";
GC> seems to suggest a version conflict.

 This was exactly my thought even before I read your message to the end. I
think README.auto fails to mention that you must also have aclocal of the
same version as automake. So what does "aclocal --version | head -n 1"
return on your system?

 On mine I seem to have all versions of aclocal known to humanity:

% ls -o /usr/bin/aclocal*
lrwxrwxrwx 1 zeitlin    25 Mar 30  2007 /usr/bin/aclocal -> 
-rwxr-xr-x 1 zeitlin 30647 Oct 16  2006 /usr/bin/aclocal-1.10
-rwxr-xr-x 1 zeitlin 12155 Nov 13  2006 /usr/bin/aclocal-1.4
-rwxr-xr-x 1 zeitlin 14093 Nov 12  2006 /usr/bin/aclocal-1.5
-rwxr-xr-x 1 zeitlin 13285 Nov 12  2006 /usr/bin/aclocal-1.6
-rwxr-xr-x 1 zeitlin 12387 Nov 12  2006 /usr/bin/aclocal-1.7
-rwxr-xr-x 1 zeitlin 19348 Nov 12  2006 /usr/bin/aclocal-1.8
-rwxr-xr-x 1 zeitlin 19848 Nov 12  2006 /usr/bin/aclocal-1.9

But the important thing is that aclocal link points to the version of
aclocal matching automake used:

% ls -o /etc/alternatives/a*
lrwxrwxrwx 1 zeitlin 20 Mar 30  2007 /etc/alternatives/aclocal -> 
lrwxrwxrwx 1 zeitlin 21 Mar 30  2007 /etc/alternatives/automake -> 
lrwxrwxrwx 1 zeitlin 35 Mar 30  2007 /etc/alternatives/automake-info -> 

Is it the same on your system?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]