[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: [lmi] How to build lmi from source on GNU/Linux

From: Vadim Zeitlin
Subject: Re[2]: [lmi] How to build lmi from source on GNU/Linux
Date: Sun, 21 Sep 2008 15:41:46 +0200

On Sun, 21 Sep 2008 11:00:21 +0000 Greg Chicares <address@hidden> wrote:

GC> On 2008-09-20 22:41Z, Vadim Zeitlin wrote:
GC> > 
GC> >  I'll try to install this 1.10.1 version here to test it too (I see that 
GC> > is available as a choice in Cygwin setup) a.s.a.p. For now I just tested
GC> > with automake 1.10 and it worked without any problems. So an alternative
GC> > could be to downgrade your Cygwin automake to 1.10 (it is called 1.10-1 in
GC> > setup, not to be confused with 1.10.1-0 which is your version).
GC> Okay, I downgraded, but I still get the same error message.

 And in the meanwhile I upgraded (this required closing a dozen or so of
instances of zsh I had running which is why I took so long to do it...) and
everything still works just fine for me with automake 1.10.1 :-( I do get
the same error message as you if I make an intentional typo in the macro
name, e.g.:

configure.ac:82: error: possibly undefined macro: AC_MSG_ERRORR

but everything just works if the macro has the correct name. I also tried
running "autoconf --trace=AC_MSG_ERROR" but this just gives the expectedly
long list of places where it is used.

GC> $./autogen.sh
GC> Setting up build system for lmi:
GC>  - aclocal
GC>  - libtoolize
GC>  - autoconf
GC> configure.ac:82: error: possibly undefined macro: AC_MSG_ERROR

 I admit I simply don't understand how is it possible for this to happen.
AC_MSG_ERROR is a standard autoconf macro, defined in
/usr/share/autoconf/autoconf/general.m4 as a synonym for AS_ERROR. The
latter itself is defined in /usr/share/autoconf/autoconf/m4sugar/m4sh.m4
and must be expanded by autoconf. The last thing I can think of asking you
to do is to run "autoconf -v" (after removing autom4te.cache once again).
Does the m4 command it runs use the correct --include=/usr/share/autoconf
option? I can only think that somehow either this option is not used or
this directory contains wrong files.

 Finally (this is the *very* last thing) I wonder if globally replacing
AC_MSG_ERROR with AS_ERROR in configure.ac might fix (hide, really) the
problem as it seems that your autoconf is happy with AS_ERROR because it is
used inside AC_INIT which occurs before the first AC_MSG_ERROR in the

 In any case, it seems clear that this is a Cygwin installation problem as
AC_MSG_ERROR must work in a working autoconf installation (this doesn't
even have anything to do with automake nor aclocal) but it equally clearly
doesn't help us much.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]