[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
RE: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attributeignore
RE: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attributeignored
Fri, 21 Sep 2007 13:20:11 +0100
On Fri, 2007-09-21 at 14:09 +0200, Goldschmidt Simon wrote:
> > > - PACK_STRUCT_FIELD(struct ip_addr src);
> > > - PACK_STRUCT_FIELD(struct ip_addr dest);
> > > + NOPACK_STRUCT_FIELD(struct ip_addr src);
> > > + NOPACK_STRUCT_FIELD(struct ip_addr dest);
> > I'm happy with this in principle - avoiding compiler
> > warnings, if they're genuine, is on the whole a good idea -
> > but I don't like the "NOPACK" name. How about calling it
> > PACK_STRUCT_STRUCTFIELD instead?
> > Not the most elegant of names perhaps, but better defines
> > what it's trying to achieve.
> And what about the u8_t types, then? If they also don't require packing,
> we would have to define something like PACK_STRUCT_BYTE_FIELD...
Yes. I'd also be happy with just not wrapping those entries with
PACK_STRUCT_FIELD if others would prefer that. To be honest, I'm happy
with it as it is if that's the consensus! While it's good to avoid the
warning, it's not the most important thing.
I do find it a little odd that the compiler thinks these types do not
need packing though. Although gcc might align things to the natural
size of the type (and so u8_t will always be "packed") I don't think
it's a definite requirement that a compiler do this. I seem to remember
this being discussed quite heatedly at length a few years ago though, so
I'm keen to avoid that again.