[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] Virtual machines in the same host (bridge).

From: Norberto R. de Goes Jr.
Subject: Re: [lwip-users] Virtual machines in the same host (bridge).
Date: Tue, 10 Feb 2015 09:43:00 -0200

Hi Sylvain and Valery.

I found other configuration instructions (http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge) about bridge filters:

No traffic gets trough (except ARP and STP)

Your kernel might have ethernet filtering (ebtables, bridge-nf, arptables) enabled, and traffic gets filtered. The easiest way to disable this is to go to /proc/sys/net/bridge. Check if the bridge-nf-* entries in there are set to 1; in that case, set them to zero and try again.

 # cd /proc/sys/net/bridge
 # ls
 bridge-nf-call-arptables  bridge-nf-call-iptables
 bridge-nf-call-ip6tables  bridge-nf-filter-vlan-tagged

 # for f in bridge-nf-*; do echo 0 > $f; done
... "

Then I tried that configuration just in the VM#1 (lwip use). Now finally the ping works fine!

Thanks you very much! This issue is solved.

2015-02-07 18:18 GMT-02:00 Valery Ushakov <address@hidden>:
Sylvain Rochet wrote:

> On Fri, Feb 06, 2015 at 01:29:28PM -0200, Norberto R. de Goes Jr. wrote:
>> I think the problem is in the my virtual environment (vm?s). I run the
>> application in real servers and the ping replies have success.
>> Thank you very much.
> Yes, this is exactly what I previously said, the problem is (probably)
> because your VM host bridge does not accept learning of foreign MAC
> address.

"Internal Network" is not a VM/host bridge, just a piece of virtual

As the first mail of the thread said:

| But I did not get success still.  The pings from VM#2 go from the
| ethernet to the "br0"(VM#1) device and after to the "tap0" device.
| There the lwIP generates an answer and sends it to the asking
| host. But then the packages disappear.  They do not go back to the
| "br0" device (seen with dcpdump).

So the pongs seems to be lost between tap0 and br0 inside VM1.

BTW, VBox "NAT Network" is basically the same "Internal Network" with
an extra proxy process connected to it and that proxy happens to be
lwip-based :)

The notes I refered to in my previous mail are from the initial
prototype of it that I hacked together using unixsim with tap bridged
to VM's internal network connection, i.e. the setup that is used by
Norberto, as far as I understand.


lwip-users mailing list

Norberto R. de Goes Jr.
Tel.: +55 19 3705-4241 / Fax: +55 19 3705-6125

reply via email to

[Prev in Thread] Current Thread [Next in Thread]