[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Acessing the GUI

From: Paulo S. P. Silveira
Subject: Re: Acessing the GUI
Date: Sun, 07 Sep 2008 11:19:46 -0300

Dear John,

I installed from a rpm. There is a good chance that is the
problem because I tried kfind, searching from /, and there is no anywhere. Even if I could find it, I would not know where
is the LD_LIBRARY_PATH environment variable. 

Since you told me that the rpm package is probably buggy, I took your
comments as a recommendation to compile psppire.

It was a long run, and I decided to report what happened hoping that it
may be useful to other people. Please, if someone intends to follow me,
read all this email before you start. I am warning it is not a success
story or a straightforward "howto" guide. At the end I succeeded, but I
am reporting all the tripped steps before I got success. Please, learn
from my mistakes.

Before I start, I have an additional comment. I like Linux a lot, and I
am happy with Fedora since I left Windows. I am using Fedora for two
years now and my Fedora 9 update has three weeks only. I am not a geek;
I intend to be a simple Linux user. However, initiated guys in Linux
assume that everything is transparent. Can you figure an E.T. just
arrived on Earth, to whom we give the instructions:
"Before we can eat, please go to the bathroom and wash your hands."?
Do you think he/she is going to get it right in the first time? Geeks
have to realize that usual things have no instructions anywhere. Newbies
like me may have a hard time to follow instructions to fix things. The
dialog between an E.T. and a Geek would look like:
E.T.: - What is the map to find the bathroom (or what is a bathroom in
the first place)
Geek: - Go to the third door at left. Open the door. A bathroom is a
room where you can wash your hands, among many other functions.
E.T. - Thus, what do we use to wash hands?
Geek: - Use water and soap
E.T. (coming back): - I found there are many sources of water in the
bathroom. Which one should I use?
That's my feeling in the Linux world. :-)

If you read my initial message (which is not copied here), Bug Buddy was
complaining about the sound of my computer. In fact, the sound wasn't
working. It is another issue: Fedora 9 has having sound issues that seem
hard to fix. I did in a pragmatic way. Using the terminal as root I
first updated my system. If you don't know how, go to
Application->System Tools->Terminal and type
# su
(root password)
# yum -y update

and, after that, I used a nice tool called Easylife. You can find it
Sound was fixed, but I still cannot run PSPP.

My quest started. I downloaded the last release from
unpacked it (it is a tar.gz), opened a terminal, moved to the directory
where the PSPP installation files were unpacked, and did the trick I now
about compilation:
# ./configure
# make
# make install

I got errors.
./configure ended with
configure: error: The following required prerequisites are not
You must install them before PSPP can be built:
        libplot (or use --without-libplot)
        libgsl (version 1.4 or later)

I checked with yum search:
- libplot seems to part of plotutils.i386, which was already installed
in my computer.
- the other two does not appear with yum. 

I've decided to ignore the libplot issue for a while, and I goggled the
gsl thing, to find:
"The GNU Scientific Library (GSL) is a numerical library for C and C++
programmers. It is free software under the GNU General Public License."
Under the download section I found many files, thus I got what I
believed were the most recent ones:
(I guess that if there is a patch, it has to be used)
Then I unpacked gsl-1.9.tar.gz and using the terminal, moved to the
directory where it was to run, and again...
make install
(there is a INSTALL file with instructions if this traditional
configure, make, make install does not work in your system)
It took a very long time but ended without errors... Specially "make"
was a long procedure, calling gcc (which means it was compiling)

Then I executed the patch, only to get more errors:
# chmod u+x gsl-1.9-1.10.patch
# gsl-1.9-1.10.patch
diff: gsl-1.10/acconfig.h: No such file or directory
./gsl-1.9-1.10.patch: line 2: gsl-1.9: command not found
./gsl-1.9-1.10.patch: line 3: ---: command not found
./gsl-1.9-1.10.patch: line 4: gsl-1.9: command not found
... etc etc etc etc until
./gsl-1.9-1.10.patch: line 162: -: command not found
./gsl-1.9-1.10.patch: line 164: syntax error near unexpected token
./gsl-1.9-1.10.patch: line 164: `! AC_DEFUN([AM_AUX_DIR_EXPAND],'

I, then, realized that the patch name is gsl-1.9-1.10.patch !
How come, if I got 1.9, which is the last one, the name suggests I am
going from 1.9 to 1.10? Well, the download directory is a trap in
alphabetic order: the last one is 1.11. I, then, downloaded, unpacked,
and again tried:
# cd /home/silveira/Download/PSPP/gsl-1.11
# ./configure
# make
# make install
(of course, there was no patch this time)
This installation was ok. 

I then moved back to the pspp installation directory to try again:
# cd /home/silveira/Download/PSPP/pspp-0.6.0
# ./configure
It consistently ended with:
configure: error: The following required prerequisites are not
You must install them before PSPP can be built:
        libplot (or use --without-libplot)

I rather to install instead of use "without". The name suggests me that
without libplot I have no way to plot. A statistics package that has no
plots is not interesting...

I tried, then, to remove plotutils and reinstall it. It was useless, as
I report below, but at this point I have no idea if it was or wasn't
part of the solution. I typed:
# yum remove plotutils
(in which libplot is in), getting a warning:

Dependencies Resolved
 Package                 Arch       Version          Repository    Size 
 plotutils               i386       2.5-5.fc9        installed     3.7 M
Removing for dependencies:
 inkscape                i386       0.46-2.fc9       installed      57 M
 pspp                    i386       0.6.0-5.fc9      installed     3.5 M
 pstoedit                i386       3.45-2.fc9       installed     1.6 M
 tetex-tex4ht            i386       1.0.2008_02_28_2058-3.fc9 installed
9.9 M

Transaction Summary
Install      0 Package(s)         
Update       0 Package(s)         
Remove       5 Package(s)         

Is this ok [y/N]: 

Well... I have no geeks around to ask for orientations, then I knew:
1. inkscape is a vectorial editor I like, but I can easily reinstall
later through yum.
2. the pspp that appears here is probably the not working version, thus
I believed it would be convenient to remove it.
3. I have no idea what pstoedit is... whatever.
4. tetex-tex4ht is something related to TeX that I use to write paper. I
could risk it. If something goes wrong with TeX, it is another issue
that I can solved later.

Thus, I've decided to proceed. After the removing I reinstalled
plotutils with:
# yum install plotutils

The reinstallation was ok, but I got frustrated when I went back to pspp
to try again...
# cd /home/silveira/Download/PSPP/pspp-0.6.0
# ./configure
... only to find it still complaining about libplot. It seems it is not
finding libplots. Since I do not know where and how to set environment
variables (please, wash your hands :-), I, then, found:
and downloaded the most recent release to compile, in the hope it would
fix environment variables, wherever they are:
# cd /home/silveira/Download/PSPP/plotutils-2.5
# ./configure
# make
# make install

and then, I've tried com compile pspp another time
# cd /home/silveira/Download/PSPP/pspp-0.6.0
# ./configure
(this time it said: 
"PSPP configured successfully.")
I was happily typing
# make
which ended with:
collect2: ld returned 1 exit status
make[2]: *** [src/ui/terminal/pspp] Error 1
make[2]: Leaving directory `/home/silveira/Download/PSPP/pspp-0.6.0'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/silveira/Download/PSPP/pspp-0.6.0'
make: *** [all] Error 2

Oh! My...
>From Google I learned
"Do you have any other copies of these libraries? For example, do you
have multiple copies of libdl.a? It looks like your machine is trying to
link to the wrong ones."
It is probably the case, since I have the other plotutils that were
yummed in my system.

I also found
"A workaround for that problem is given in the PSPP README:
       * If you use GCC 4.3 or later to compile PSPP, along with any
         version of the GNU Scientific Library (GSL) released as of
         this writing (June 2008), then you will need to specify the
         -fgnu89-inline flag to the compiler on the "configure"
         command line: "./configure CFLAGS=-fgnu89-inline"."

Let's try, then:
# ./configure CFLAGS=-fgnu89-inline
# make
(the collect2 error was gone!)
# make install
(there was no installation errors)

SUCCESS !!!!!!!!!!!!!!!!!!!!!!!!!!

Then, as a regular user (silveira) I could not find any icon for PSPP or
psppire (which is the difficulty many users are finding to access the
GUI). I solved it by locating the file at

One can created a launcher in the desktop. Do you know how? (if not, I
can show you where is the sink and what is the soap). Minimize all
windows and click in an empty space with the right button. Select
"Create Launcher" and fill in with:
Type: Application
Name: PSPP
Command: /usr/local/bin/psppire
Comment: Statistics
Click ok and you're done. Double click the new icon and go.

My PSPP's GUI seems to be working now. I can go to the menus and do some
simple things (I tried Descritive statistics). Only with time I will
know if everything is ok, but it was a big step for me so far.

By the way, I am now going to reinstall inkscape and the other stuff I
destroyed along the way :-).

I hope it helps. I thank again John, who gave me the start and
inspiration to solve this issue.

Have a nice day,


On Sun, 2008-09-07 at 07:29 +0800, John Darrington wrote:
> On Sat, Sep 06, 2008 at 06:34:28PM -0300, Paulo S. P. Silveira wrote:
>      I am a Fedora user, which installs psppire. However, I cannot use it.
>      PSPP's GUI starts, but it immediately crashes when I touch any menu.
>      When it crashes, Bug Buddy appears to generate a report that is
>      meaningless for me (copied below). For some reason it goes to evolution
>      and shows, in that report, my emails, complaining that it cannot find my
>      passwords. My Fedora 9 is freshly installed, so I do not think that it
>      is a Fedora problem. 
>      Please, can someone tell me how to make the GUI work for PSPP? I tried
>      to Google it to check if it is a known bug, without success. 
> I'm guessing that this is because your installation cannot find the
> library.  The easiest way around this is to set your
> LD_LIBRARY_PATH environment variable to point to the directory where
> it is located.
> If you compiled psppire yourself, then the location is probably
> /usr/local/lib/pspp If you installed it from the Fedora .rpm file then
> it may be somewhere else.  If you're using the .rpm, then this
> probably means there is a bug in that package, and you should report
> it to the maintainer.
> J'     

reply via email to

[Prev in Thread] Current Thread [Next in Thread]