[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-arm] Booting Cortex-M3 Linux kernels in qemu

From: Peter Maydell
Subject: Re: [Qemu-arm] Booting Cortex-M3 Linux kernels in qemu
Date: Fri, 15 Jun 2018 10:16:50 +0100

On 14 June 2018 at 22:54, Guenter Roeck <address@hidden> wrote:
> qemu supports a number of boards with Cortex-M3 CPU. One board supported
> by both qemu and Linux is an385.
> As part of my kernel testing effort, it would be great to be able to boot
> a non-MMU kernel. However, nothing I tried works.
> Is it possible to boot a Cortex-M3 Linux kernel with qemu ? If yes, does
> anyone happen to know how to do it ?

I've never tried to boot Linux, only a few RTOS-ish things.
mps2-an385 is probably a reasonably good choice to start with.
Note that it is missing quite a lot of devices, so you might
need to configure Linux not to try to use them (and also
let us know which ones would be useful for us to implement...)
If you pass QEMU the command line -d unimp option it should log
accesses to ranges and devices we don't implement, which may
throw up some useful hints.

Also for M-profile I'd suggest always trying with the most
recent QEMU if you aren't already, since we've been working
actively on it recently.

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]