[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-block] [Qemu-devel] [PATCH v12 29/36] qobject: Rename qtype_co
Re: [Qemu-block] [Qemu-devel] [PATCH v12 29/36] qobject: Rename qtype_code to QType
Thu, 19 Nov 2015 08:44:27 +0100
Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux)
Eric Blake <address@hidden> writes:
> On 11/18/2015 11:25 AM, Markus Armbruster wrote:
>> Eric Blake <address@hidden> writes:
>>> The name QType is more in line with our conventions for qapi
>>> types, and matches the fact that each enum member has a prefix
>>> of QTYPE_.
>>> Signed-off-by: Eric Blake <address@hidden>
>> At this point, the connection to QAPI is unobvious.
>> You can either point to CODING_STYLE, which ask for type names in
>> CamelCase, or to the next patch.
> How about:
> The name QType matches our CODING_STYLE conventions for type names in
> CamelCase. It also matches the fact that we are already naming all the
> enum members with a prefix of QTYPE, not QTYPE_CODE. And doing the
> rename will also make it easier for the next patch to use QAPI for the
> enum, which also wants CamelCase type names.
> Feel free to touch up the commit message as you see fit.