[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/3] Add "qemu_reset_vcpu"

From: Lluís Vilanova
Subject: Re: [Qemu-devel] [PATCH 1/3] Add "qemu_reset_vcpu"
Date: Fri, 16 Sep 2011 20:43:52 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Jan Kiszka writes:

> On 2011-09-16 19:01, Lluís Vilanova wrote:
>> Mimics the already-existing "qemu_init_vcpu".

> Bad name as it implies something important happens inside. Call it
> trace_reset_vcpu because that is what it will do.

I just thought it is much cleaner to call a generic "qemu_reset_vcpu"
function that _might_ do something related to resetting the vCPU state,
regardless of whether there is a tracing event for it or not.

Otherwise if someone wants to add some generic vCPU-resetting code in
the future, the tracing function might end up in the target-specific
code instead of the generic qemu code.

If you still think this is a bad idea I'll resend a patch with both
events renamed into trace_vcpu_init/trace_vcpu_reset.


 "And it's much the same thing with knowledge, for whenever you learn
 something new, the whole world becomes that much richer."
 -- The Princess of Pure Reason, as told by Norton Juster in The Phantom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]