[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find

From: David Fernandez
Subject: Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find ttyS0.
Date: Mon, 8 Nov 2021 21:19:05 +0000

On 08/11/2021 20:57, David Fernandez wrote:
> On 08/11/2021 20:50, Peter Maydell wrote:
>> On Mon, 8 Nov 2021 at 20:22, David Fernandez 
>> <david.fernandez@sen.com> wrote: Does the x86-64 host still work OK 
>> if you run it with KVM turned off
>> (ie matching the aarch64 host setup) ?
>>> Have not tried that... is there an easy way/option to run that test? Or
>>> do I need
>>> to compile from sources in Fedora?
>> As long as your QEMU commandline doesn't have -enable-kvm or any
>> other kvm-related option in it it should default to emulation.
> I believe I used to run without it... I'll recheck and confirm.

So yes, I run without -enable-kvm in the command line:

 From my first email:

I run it like this:

qemu-system-x86_64 \
   -boot order=dc,menu=on \
   -cdrom ubuntu-18.04.6-live-server-amd64.iso \
   -nographic \
   -serial mon:stdio \
   -kernel ufm/vmlinuz \
   -initrd ufm/initrd \
   -append 'boot=casper console=ttyS0 ---' \
   -m 16384 \
   -drive  file=ufm/ufm.fd0,format=raw,if=floppy \ <= empty image to 
avoid ubuntu complaining about fd0.
   -drive  file=ufm/ufm.img,format=raw,if=ide \
   -netdev bridge,br=virbr0,id=net0 \
   -device virtio-net-pci,netdev=net0,id=nic1 \
   -device usb-ehci,id=ehci

>>>>> Hopefully, some experts around here can help me with that if it is a
>>>>> known thing (I google around but other than mentioning that 2.11 
>>>>> is too
>>>>> old, could not find any clear reason about this problem).
>>>> For aarch64 host, I would be a bit dubious about running 2.11 or 
>>>> 2.12 --
>>>> they are both absolutely ancient in QEMU terms.
>>> Is there a specific branch I should use? Could not see more than 
>>> 2.12 in
>>> git.qemu.org regarding stable branches, but happy to compile and try 
>>> any
>>> other.
>> We switched some time ago to using tags rather than branches;
>> you could use the v6.1.0 tag for the most recent release, or
>> master for bleeding-edge.
> As noted above, I did not realize straight away that the fedora 
> version is 5.2.0...
> I'll try 5.2.0 first, then 6.1.0 (I tried master but the problem was 
> still there).
> Then I might do the newer guest version to see what happens.

Right, checked out v5.2.0 tag, recompiled (no --enable-spice-protocol, 
only --enable-spice, and no --enable-lto), and the problem is still there

Hopefully doing a git checkout -f v5.2.0 is enough (not sure if I need 
some other option to force some submodule change... I beleieve the 
configure or make do that). The qemu-system-x84_64 -version gives 5.2.0, 
as in the host, but it still does not find the ttyS0 device.

Will try now 6.1.0 then download the Ubunto 20 iso (and extract the 
vmlinuz and initrd) and see if that changes anything.

>> -- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]