[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find

From: David Fernandez
Subject: Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find ttyS0.
Date: Mon, 8 Nov 2021 23:07:23 +0000

On 08/11/2021 22:00, David Fernandez wrote:
> On 08/11/2021 21:19, David Fernandez wrote:
>> On 08/11/2021 20:57, David Fernandez wrote:
>>> On 08/11/2021 20:50, Peter Maydell wrote:
>>>> On Mon, 8 Nov 2021 at 20:22, David Fernandez 
>>>> <david.fernandez@sen.com> wrote:
>>>>> Is there a specific branch I should use? Could not see more than 
>>>>> 2.12 in
>>>>> git.qemu.org regarding stable branches, but happy to compile and 
>>>>> try any
>>>>> other.
>>>> We switched some time ago to using tags rather than branches;
>>>> you could use the v6.1.0 tag for the most recent release, or
>>>> master for bleeding-edge.
>>> As noted above, I did not realize straight away that the fedora 
>>> version is 5.2.0...
>>> I'll try 5.2.0 first, then 6.1.0 (I tried master but the problem was 
>>> still there).
>>> Then I might do the newer guest version to see what happens.
>> Right, checked out v5.2.0 tag, recompiled (no 
>> --enable-spice-protocol, only --enable-spice, and no --enable-lto), 
>> and the problem is still there
>> Hopefully doing a git checkout -f v5.2.0 is enough (not sure if I 
>> need some other option to force some submodule change... I beleieve 
>> the configure or make do that). The qemu-system-x84_64 -version gives 
>> 5.2.0, as in the host, but it still does not find the ttyS0 device.
>> Will try now 6.1.0 then download the Ubunto 20 iso (and extract the 
>> vmlinuz and initrd) and see if that changes anything.
> Tried v6.1.0 from a clean qemu repo, just to be sure that make checks 
> out the right submodules, and still the same, so will try Ububntu 
> 20... this probably take until tomorrow to get results... let you know.

Right, seems that the torrent download for the iso was really quick at 
this time, so I tested qemu 6.1.0 with Ubuntu 20.04.3 in both my intel 
desktop and the aarch64 Jetson, and it works fine in my desktop and 
fails in the same way in the Jetson.

Any ideas?

>>>> -- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]