[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find

From: David Fernandez
Subject: Re: Guest Ubuntu 18.04 fails to boot with -serial mon:stdio, cannot find ttyS0.
Date: Thu, 11 Nov 2021 12:42:13 +0000

On 11/11/2021 11:23, Peter Maydell wrote:
> [No suele recibir correo electrónico de peter.maydell@linaro.org. Obtenga 
> información acerca de por qué esto es importante en 
> http://aka.ms/LearnAboutSenderIdentification.]
> On Wed, 10 Nov 2021 at 18:56, David Fernandez <david.fernandez@sen.com> wrote:
>> As I have not hear anything yet, I thought I would summarize the current
>> status
>> for this problem. Please, let me know if any other tests or information are
>> needed.
>> I am running qemu-system-x86_64 v5.2.0 (also tried v6.1.0 and top of
>> master) on:
>>      - aarch64 (Jetson AGX Xavier) with Ubuntu 18.04.5 as a host
>> (compiled from
>>        git sources as distro version for it was 2.11, which is too old),
>> and on
>>      - x86_64 (my laptop) with Fedora 34 as a host (here the
>> qemu-system-x86_64
>>        distro version is 5.2.0).
>> Running Ubuntu 18.04.6 server install cdrom (also tried Ubuntu 20.04.3)
>> as the
>> guest.
>> The following services fail on the Jetson, but not on the laptop. The
>> first one
>> is the ttyS0 console, which seems the most important thing as it is provided
>> directly by the virtual emulation (-serial mon:stdio):
>> [ TIME ] Timed out waiting for device dev-ttyS0.device.
> I'm pretty sure this isn't actually a problem with the emulation
> of the serial device (after all you are seeing all these messages
> so far on the serial console, right?).

Right, may be it is not, I do not know what the problem is.

>   The problem is that the
> udev machinery that creates nodes in /dev is being too slow
> (or possibly is failing for some other reason, but given all the
> other timeouts I'm guessing "everything is too slow") and so
> the systemd unit that is waiting for /dev/ttyS0 to be created
> times out.

What is a bit puzzling is that this is supposed to all run in an 
emulated machine having its own simulated time, so yes things are slow, 
but everything should happen as expected, just slowly.

I guess I will compile from sources on Fedora and see if I get the same 
problem, as it is a bit hard to believe that the only way to run qemu is 
to have a high end machine dedicated just to run an install cd.

If the qemu compiled from sources on Fedora fails, then we should 
conclude that there is something about the distro supplied qemu that is 
not properly done when compiling from sources as I do... may be my fault 
or a bug, but

As mentioned, let me know if you know of something that could fix this.


> -- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]