[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] Booting FreeBSD PowerPC64 on qemu-system-ppc

From: Super Bisquit
Subject: Re: [Qemu-ppc] Booting FreeBSD PowerPC64 on qemu-system-ppc
Date: Tue, 13 Mar 2012 11:20:09 -0400

On Mon, Mar 12, 2012 at 9:36 PM, Alexander Graf <address@hidden> wrote:

Am 13.03.2012 um 02:26 schrieb Super Bisquit <address@hidden>:

> Qemu-0.15.1 on an iMac G4 running Debian Squeeze. I've tried with both
> openbios-ppc and ppc_rom.bin using qemu-system-ppc64 and
> qemu-system-ppc.
> Images used were Fedora 16 ppc dvd, FreeBSD ppc64 boot only, and
> OpenBSD macppc 5.0.
> Yaboot would not load the system. OpenBSD stalled with the same error
> message as earlier. FreeBSD also had previous error messages.
> By the way, where are the older openbios images?

Please see the mailing list archives for specific version information. You might want to just try whatever came with 0.14. Or try 1.0 ;).

Also, please dom't top post. It makes the conversation unreadable and is considered very rude in most open souce projects - including QEMU.

The  new qemu wiki does not have a page to access the rom images. I built a openbios-unix (for ppc) rom and it did not work. This was done on the imac G4 with debian.
Also, changing the version numbers and entering on the url did not work.
$ qemu-system-ppc64 -cpu 970 -hda *img -cdrom *iso -display sdl -boot d
Co-routine is yielding to no one
Abort trap (core dumped

This message is from qemu on FreeBSD Quicksilver G4.

Also, other ppc roms such as the 405 are not in the package by default.

$ qemu-system-ppc64 -cpu POWER7 -hda *img -cdrom *iso -display sdl -boot d -M taihu
taihu_405ep_init: register cpu
ppc4xx_opba_init: offset 00000000ef600600
ppc405_gpio_init: offset 00000000ef600700
ppc4xx_gpt_init: offset 00000000ef600000
taihu_405ep_init: register BIOS
Load BIOS from file
qemu: could not load PowerPC bios 'ppc405_rom.bin'

Attachment: qemu-system-ppc64-crash.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]