[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-ppc] Problem booting qemu-system-ppc with cpu e500XX and machine m

From: Badrinath Sriman
Subject: [Qemu-ppc] Problem booting qemu-system-ppc with cpu e500XX and machine mpc8544ds
Date: Fri, 29 Jun 2012 17:43:16 +0530

I have downloaded the latest qemu source code qemu-1.1.0-1.tar.bz2 and compiled 
it in my host (x86/ubuntu combination) to generate qemu-system-ppc. I just used 
configure with the --target-list = ppc-softmmu option. I am trying to emulate a 
netbsd/P2020 platform combination as a guest. The problem is when I run the 
following command:

qemu-system-ppc -cpu e500v2 -m mpc8544ds -cdrom <my_bootable.iso) -boot d,

it immediately goes directly to the qemu monitor window. The guest VM or 
terminal emulation window is not at all appearing. Hence, I guess that there is 
a problem in qemu starting the guest, even before loading the guest kernel. 
Could you please let me know whether I am missing something?

If I start qemu-system-ppc without the -cpu and -m option, then there are 
problems while booting the netbsd kernel. Looks like an "SPR invalid access to 
48" is got. The SPR 48 register is the process id register in e500 based cores. 
I assumed therefore that the SPR register no: 48 is not emulated in the default 
qemu-system-ppc (without the cpu and machine options) and so tried with the 
above cpu and machine options.

Kindly send your reply to my email address, as I am not part of the qemu-ppc 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]