[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] Problem booting qemu-system-ppc with cpu e500XX and machi

From: Badrinath Sriman
Subject: Re: [Qemu-ppc] Problem booting qemu-system-ppc with cpu e500XX and machine mpc8544ds
Date: Sat, 30 Jun 2012 14:13:05 +0530

Thanks a lot for your immediate reply. Couple of points:
a) I have been using -M option only before mpc8544ds, as I am also using the -m 
option for specifying the memory. It was a typo error on my part in my mail. 
Sorry about the same.
b) From your reply, I think that the key thing as to why the guest window does 
not pop up seems to be that the -M mpc8544ds option mandatorily expects a 
-kernel and -initrd option, whereas I have been trying to boot it through the 
usual -cdrom <bootable.iso> -boot d option, as my understanding of qemu was 
that -kernel option was supported only for linux as guest OS. I shall now try 
to use the -kernel option for specifiying a netbsd kernel and let you know the 
result. Since netbsd has the ramdisk built inside the kernel itself (unlike 
linux where we can give kernel and ramdisk separately), will the -M mpc8544ds 
work with the -kernel option alone, or does it expect a -initrd option too as a 
mandatory parameter?


From: Alexander Graf address@hidden
Sent: Friday, June 29, 2012 5:49 AM
To: Badrinath Sriman
Cc: address@hidden
Subject: Re: [Qemu-ppc] Problem booting qemu-system-ppc with cpu e500XX and 
machine mpc8544ds

On 29.06.2012, at 14:13, Badrinath Sriman wrote:

> Hi,
> I have downloaded the latest qemu source code qemu-1.1.0-1.tar.bz2 and 
> compiled it in my host (x86/ubuntu combination) to generate qemu-system-ppc. 
> I just used configure with the --target-list = ppc-softmmu option. I am 
> trying to emulate a netbsd/P2020 platform combination as a guest. The problem 
> is when I run the following command:
> qemu-system-ppc -cpu e500v2 -m mpc8544ds -cdrom <my_bootable.iso) -boot d,

This needs to be -M. -m is used to specify the amount of memory you pass into a 
guest. -M picks the emulated machine model.

> it immediately goes directly to the qemu monitor window. The guest VM or 
> terminal emulation window is not at all appearing. Hence, I guess that there 
> is a problem in qemu starting the guest, even before loading the guest 
> kernel. Could you please let me know whether I am missing something?

Currently, the mpc8544ds machine doesn't execute u-boot, but can only call into 
guest kernels directly through -kernel and -initrd. I haven't tried to run 
NetBSD yet, so also expect things to be slightly bumpy :).

> If I start qemu-system-ppc without the -cpu and -m option, then there are 
> problems while booting the netbsd kernel. Looks like an "SPR invalid access 
> to 48" is got. The SPR 48 register is the process id register in e500 based 
> cores. I assumed therefore that the SPR register no: 48 is not emulated in 
> the default qemu-system-ppc (without the cpu and machine options) and so 
> tried with the above cpu and machine options.

The default machine on qemu-system-ppc when not passing in -M is g3beige, which 
can not properly run an e500 NetBSD kernel :).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]