[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Screen terminal freezes

From: Edmond Rodriguez
Subject: Re: Screen terminal freezes
Date: Fri, 30 Aug 2013 16:41:16 -0400

Thanks for the link.  The Ctl sequences do not seem to be an issue, I have tried several and they seem fine (but not for the freeze problem).   

I do notice that sending SIGHUP to screen does fix it (at least the terminal, but maybe not the process that was writing to the terminal), though I have also lost the screen session doing that.   I need to try more times, and as I mentioned it's an intermittent problem, though it is frequent enough to know it will happen a few times. 



On Thu, Aug 29, 2013 at 5:54 PM, wes <address@hidden> wrote:
On Wed, 28 Aug 2013, Edmond Rodriguez wrote:

I am running gnu screen version 4.00.02.

Everyone once in a while (but consistently) a terminal will freeze
up while printing output and there is no way that I know of to
unfreeze it.

CTL A q does not help and I tried about every command available in
the help.

I can create other terminals within the screen, but cannot usually
reconnect to the screen session it if I detach it.  The frozen
terminal remains just that (frozen) until I terminate the entire
screen session.

I also tried the "wipe" function of the screen command, though I
have not seen a need for it.

Any clue what might be happening?

"GNU Screen - Bugs: bug #11610, XON (Ctrl-S) halts screen 4.0.2"
                                ^^^[xoff, iiuc]

btw, you do not mention trying...

 ctrl-a ctrl-q

...and perhaps that is because ^q is not mapped to xon in your
installation.  but if it is, you might want to give that a try.  (ftr,
i am using version 4.01.00devel (GNU) 2-May-06 in debian 7.1.)

i make the suggestion because on my installation "ctrl-a ctrl-q"
behaves differently than "ctrl-a q".  namely, the former happens to
work and the latter does not appear to work (both in a vt and in
xterm).  this is despite the fact that my screen installation's help
command informs me that both ^Q and q are mapped to xon.

i have been assuming the discrepancy is most likely due to some
non-screen part of my environment.  because i like screen's help
command, and i like to think it would not tell me dirty, dirty lies.


screen-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]